Bug 3907 - nss_wins segfaults on x86_64
nss_wins segfaults on x86_64
Status: RESOLVED DUPLICATE of bug 3937
Product: Samba 3.0
Classification: Unclassified
Component: Client Tools
3.0.22
x64 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-02 11:29 UTC by Björn Jacke
Modified: 2006-07-17 10:26 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Jacke 2006-07-02 11:29:48 UTC
I've seen this problem already a while ago: nss_wins does not work on linux x86_64 tested with SLES9 and RHEL4. A "ping no_such_host" will segfault, the end of a strace looks like this:

open("/usr/lib64/libssl.so.0.9.7", O_RDONLY) = 4
read(4, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\340\312"..., 640) = 640
fstat(4, {st_mode=S_IFREG|0755, st_size=247610, ...}) = 0
mmap(NULL, 1268360, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 4, 0) = 0x2a967ee000
madvise(0x2a967ee000, 1268360, MADV_SEQUENTIAL|0x1) = 0
mprotect(0x2a9681c000, 1079944, PROT_NONE) = 0
mmap(0x2a9691c000, 28672, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 4, 0x2e000) = 0x2a9691c000
mmap(0x2a96923000, 2696, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x2a96923000
close(4)                                = 0
set_tid_address(0x2a959a8eb0)           = 459048
rt_sigaction(SIGRTMIN, {0x2a965c9890, [], SA_RESTORER|SA_SIGINFO, 0x2a965d0650}, NULL, 8) = 0
rt_sigaction(SIGRT_1, {0x2a965c94b0, [], SA_RESTORER|SA_RESTART|SA_SIGINFO, 0x2a965d0650}, NULL, 8) = 0
rt_sigprocmask(SIG_UNBLOCK, [RTMIN RT_1], NULL, 8) = 0
getrlimit(RLIMIT_STACK, {rlim_cur=RLIM_INFINITY, rlim_max=RLIM_INFINITY}) = 0
_sysctl({{CTL_KERN, KERN_VERSION}, 2, 0x7fbfffe820, 31, (nil), 0}) = 0
munmap(0x2a9556c000, 51365)             = 0
open("/etc/localtime", O_RDONLY)        = 4
fstat(4, {st_mode=S_IFREG|0644, st_size=837, ...}) = 0
fstat(4, {st_mode=S_IFREG|0644, st_size=837, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x2a9556c000
read(4, "TZif\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\10\0\0\0\10"..., 4096) = 837
close(4)                                = 0
munmap(0x2a9556c000, 4096)              = 0
stat("/etc/samba/smb.conf", {st_mode=S_IFREG|0644, st_size=3699, ...}) = 0
uname({sys="Linux", node="opi", ...})   = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++
Comment 1 Guenther Deschner 2006-07-05 10:13:23 UTC
You see this only on x86_64? or also in i386?
Comment 2 Guenther Deschner 2006-07-05 10:16:16 UTC
At least for i386 it should be fixed with fixes from https://bugzilla.novell.com/show_bug.cgi?id=184306 (not upstream yet)
Comment 3 Björn Jacke 2006-07-05 10:38:50 UTC
I encountered this in x86_64 only. i386 always worked for me
Comment 4 Björn Jacke 2006-07-05 11:51:28 UTC
any your proposed build fix fixes the bug Thorsten reported but it does *not* fix this segfault on x86_64, I just tested it.
Comment 5 Björn Jacke 2006-07-17 10:26:12 UTC

*** This bug has been marked as a duplicate of 3937 ***