Bug 3496 - libsmb/ntlmssp_sign.c: "nt_status" is never used
libsmb/ntlmssp_sign.c: "nt_status" is never used
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.21b
SGI IRIX
: P3 major
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-10 13:33 UTC by Jason Mader
Modified: 2006-02-13 07:26 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Mader 2006-02-10 13:33:52 UTC
cc-1552 cc: WARNING File = libsmb/ntlmssp_sign.c, Line = 239
  The variable "nt_status" is set but never used.

        NTSTATUS nt_status;
                 ^
Comment 1 Jason Mader 2006-02-10 13:34:49 UTC
In the function this appears, the return is hard coded to NT_STATUS_OK.  It looks like the return value was intended to be the nt_status variable.
Comment 2 Jeremy Allison 2006-02-13 07:26:30 UTC
Fixed, thanks !
Jeremy.