Bug 3475 - Directories mounted via FUSE as non-root cannot be connected
Directories mounted via FUSE as non-root cannot be connected
Product: Samba 3.0
Classification: Unclassified
Component: File Services
x64 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2006-02-01 14:23 UTC by Michael Rommel
Modified: 2006-04-10 07:23 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Michael Rommel 2006-02-01 14:23:22 UTC
Worked in version 3.0.10: Directories mounted as user "rommel" via encfs/FUSE can only be accessed as the user mounting the directory. The check in source/smbd/service.c in make_connection_snum worked then.

In version 3.0.14 (Fedora Core 4) and 3.0.21 (latest release) the smbd refuses with the error message:

[2006/02/01 21:54:04, 0] smbd/service.c:make_connection_snum(615)
  '/var/promo' does not exist or is not a directory, when connecting to [promo]

I feel samba should cater for setups, where root cannot access a directory but the userid that smbd switches to later in the connection setup can.
Comment 1 Gerald (Jerry) Carter 2006-04-10 07:23:51 UTC
Maybe later.  In the meantime, Samba will continue to rely upon posix 
file system semantics and the abaility of root to be able to stat
any file/directory.