Bug 3362 - Add option to normalize Unicode filenames
Add option to normalize Unicode filenames
Status: CLOSED DUPLICATE of bug 2790
Product: rsync
Classification: Unclassified
Component: core
Other All
: P3 enhancement
: ---
Assigned To: Wayne Davison
Rsync QA Contact
Depends on:
  Show dependency treegraph
Reported: 2005-12-30 07:13 UTC by Mike Bremford
Modified: 2006-03-12 02:58 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Mike Bremford 2005-12-30 07:13:57 UTC
This is somewhere between a bug and an enhancement. When moving files with Unicode names between different OSes, it would make life a lot easier if there was an option to normalize filenames to a particular unicode form on the destination.

For example, rsyncing from OS X to Linux names the files using the OS X standard, Normalization form D. Linux prefers Normalization form C, which means sharing this folder via Samba results in a number of folders that can't be accessed. Likewise when running rsync from OS X to a Windows box running cygwin. I think the best solution to this would be something like "--destination-charset=UTF-8-NFC", to rename the files from the source charset to the destionation charset.
Comment 1 Wayne Davison 2006-01-20 11:02:05 UTC
See bug #2790 comment #3 for a link to a patch that provides charset conversion.  I'd like feedback on how well this works.

*** This bug has been marked as a duplicate of 2790 ***