Bug 3328 - pdb_init_sam failed
pdb_init_sam failed
Status: NEW
Product: Samba 3.0
Classification: Unclassified
Component: Upgrade
Sparc Solaris
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2005-12-14 13:09 UTC by Jacqueline Scoggins
Modified: 2006-08-28 01:36 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Jacqueline Scoggins 2005-12-14 13:09:17 UTC
I upgraded samba from 2.2.8a to 3.0.20b and I keep getting the following errors:

[2005/12/13 16:08:23, 0] auth/auth_util.c:make_server_info_info3(1173)
  make_server_info_info3: pdb_init_sam failed!

Here is my configuration options:

configure --prefix=/local/samab  --without-ads

That went fine.

I did a make install and everything went fine.

I copied over the following files from the old samba tree:

secret.db --->  /local/samba/private/secrets.tdb - permissions 600
smbpasswd -->  same location in /local/samba/private - permissions 600

all the .tdb files in /local/samba.orig/var/locks were moved over.

smb.conf --> /local/samba/lib/smb.conf
users.map --> /local/samba/lib/users.map.

I have been trying to see what could be causing this and where did pdb cme from.  From the web sites I have seen that it must be my nsswitch.conf file.  I changed that on the server as well as in the smb.conf file and neither worked.

So I am lost now in figuring out what could be going on.

Could someone help????


Comment 1 Guenther Deschner 2006-01-13 13:54:07 UTC
Could you please post a log level 10 output from the command failing? (e.g. log.smbd), otherwise we can't even tell what is going on.