Bug 3247 - smbd dead but pid file exists
smbd dead but pid file exists
Product: Samba 3.0
Classification: Unclassified
Component: nmbd
x86 Linux
: P3 major
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2005-11-07 23:41 UTC by Robert Petrosyan
Modified: 2005-11-22 09:01 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Robert Petrosyan 2005-11-07 23:41:11 UTC
At P-IV (2.6gh/512mb/80gb intel 945 chipset) I installed Fedora Core-4 (kernel
2.6.11) in server mode with X and Gnome.

In distro there was samba-3.0.14a which installed at once with OS
Then I installed samba-swat

In system-config-services smb marked for starting when Linux start
When OS started I go to system-config-services and see that smbd not run , 
but nmbd running. And about smbd I read message 

"smbd dead but pid file exist"
"nmbd (pid NNNN) running"

And from client (Windows XP home edition) access denied
I click restart-button in system-config-services - no effect!
In terminal I run command
  service smb restart
  service smb stop
  service smb start
  smbd restart
  smbd stop
  smbd start
  put in rc.local these commands
  and restart OS

no effect!

Only one way to revive it - through swat (local or over net - no difference)
It is bad way because I may be far from server when its power fall down then up

I upgraded to samba-3.0.20b
Nothing is changed

It seems for me this bug like #949 at Jan 2004

What must I do? Where must I lookup ? May be kill pid-files manually, and start
smb-service in rc.local? 

PS. Excuse me for my poor English.
Comment 1 Robert Petrosyan 2005-11-13 13:01:30 UTC
I solved my problem by that method:

1. I turn off autostart samba by
     chkconfig smb off

2. In /etc/rc.local I added line:

     echo 'service smb start' | at now+1 minute

It seemed for me, there is not enough time for starting Samba.
when I turn off autostart Samba and after reboot I made certain of absense
'/var/run/smbd.pid' and '/var/run/nmbd.pid' and '/var/lock/subsys/smb'
Then I added line 'service smb start' in rc.local
This gave me effect 'smb dead but pid-file exist'
when I commented this line in rc.local and first command after reboot I do
'service smb start'. All correct!
After many experiments with '/etc/rc.d/init.d/smb' and '/etc/rc.d/functions' I
undestanded that they work correctly. And I thought while I login, this time is
enough for Samba is ready for correct starting.
It was strange, but sleep-command not helped. I thought that Samba start
correctly AFTER prompt.
So I added this line in rc.local
It seems for me it is bug
Comment 2 Gerald (Jerry) Carter 2005-11-14 06:58:45 UTC
You don't give enough information to determine if there is a 
bug or not.  try setting 'debug level = 10' in smb.conf and starting
Samba.  The look for an explanation of why nmbd is not starting in 
the log file.
Comment 3 Gerald (Jerry) Carter 2005-11-22 09:01:02 UTC
Closing.  This looks like a distro or configuration issue.