Bug 3133 - Pocket PC 2003 (Windows Mobile) does not save password as Pocket PC 2002 did when accessing a Samba share--It works on real windows shares though
Pocket PC 2003 (Windows Mobile) does not save password as Pocket PC 2002 did ...
Status: RESOLVED DUPLICATE of bug 1828
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.9
x86 Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-03 09:05 UTC by Hamlyn Mootoo
Modified: 2005-10-12 15:53 UTC (History)
0 users

See Also:


Attachments
Ethereal trace of Pocket PC 2003 device accessing Samba file share (5.87 KB, application/octet-stream)
2005-10-03 21:06 UTC, Hamlyn Mootoo
no flags Details
Ethereal trace of Pocket PC 2003 device accessing Windows file share (8.59 KB, application/octet-stream)
2005-10-03 21:09 UTC, Hamlyn Mootoo
no flags Details
Ethereal trace of Pocket PC 2002 device accessing Samba file share (9.91 KB, application/octet-stream)
2005-10-03 21:13 UTC, Hamlyn Mootoo
no flags Details
Ethereal trace of Pocket PC 2002 device accessing Windows file share (7.68 KB, application/octet-stream)
2005-10-03 21:16 UTC, Hamlyn Mootoo
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hamlyn Mootoo 2005-10-03 09:05:41 UTC
When using the file explorer under Pocket PC 2003 (Windows Mobile) to connect 
to a Samba file share (with user level authentication enabled), if the "Save 
Password" box is checked, the device DOES NOT save the password to be used for 
subsequent authentication.  After authenticating correctly, if the device is 
soft-reset, or simply turned off and on, and an attempt is made to re-connect 
to the same share, it prompts for the password again.  This was not the 
behavior with PDA's running Pocket PC 2002 software.  Under Pocket PC 2002, 
when the "Save Password" box was checked, the password was indeed saved, and 
the password was not prompted for again.  The PPC 2003 device has no problem 
saving the password when connecting to a share under Windows 2000. 

I am using a Dell Axim X3i (with integrated 802.11b) that is running Pocket PC 
2003, and a Toshiba e-750 running Pocket PC 2002 to do testing.  They attempt 
to connect to a Linux machine running Redhat 9.0 and have tried several 
versions of Samba from 2 to 3, all with the same result.  With the later 
versions of Samba, SPNEGO has to be toggled for the Pocket PC to authenticate 
at all. 

I have made ethereal traces on both platforms (Windows 2000 and Red Hat 9.0) 
using both PPC's as clients.  I will include these shortly
Comment 1 Hamlyn Mootoo 2005-10-03 21:06:21 UTC
Created attachment 1477 [details]
Ethereal trace of Pocket PC 2003 device accessing Samba file share

This trace is of a Pocket PC 2003 device authenticating and accessing a Samba
file share, then being soft reset and attempting to access the file share
again, but loses the password and prompts the user to enter it again.
Comment 2 Hamlyn Mootoo 2005-10-03 21:09:58 UTC
Created attachment 1478 [details]
Ethereal trace of Pocket PC 2003 device accessing Windows file share

This is a trace of a Pocket PC 2003 device accessing a windows file share, then
being soft reset and accessing the same file share again.  The Pocket PC saves
the password and does not prompt the user to enter it again.
Comment 3 Hamlyn Mootoo 2005-10-03 21:13:43 UTC
Created attachment 1479 [details]
Ethereal trace of Pocket PC 2002 device accessing Samba file share

This is a trace of a Pocket PC 2002 device accessing a Samba file share, being
soft reset, and accessing the share again. The password is saved, and the user
is not prompted upon accessing the share the second time (the desired
behavior).
Comment 4 Hamlyn Mootoo 2005-10-03 21:16:27 UTC
Created attachment 1480 [details]
Ethereal trace of Pocket PC 2002 device accessing Windows file share

This is a trace of a Pocket PC 2002 device accessing a Windows file share, then
being soft reset and accessing it again.  The device does not prompt for the
password upon re-access (the desired behavior).
Comment 5 Jeremy Allison 2005-10-12 13:57:46 UTC
Ok, I've taken a look at these traces. Samba isn't initially denying access on
the second connect - the prompt for a password is being done by the PPC2003 OS -
not Samba. The reason for this I think is that with Samba you've had to turn off
NTLMSSP SPNEGO security negotiation to get the PPC device to connect. I think
the client OS is making a policy decision not to use a stored password in this case.
What we need to do to fix this is to turn spnego negotiation back on in the
Samba server, and then for you to send me an ethereal trace of the PPC device
trying and failing to authenticate. In addition I'll need the debug level 10 log
from the smbd it's conneecting to. I may then have to send you some patches to
add debugs to track down the problem with the spnego auth.
I'm pretty sure that once we've fixed the spnego auth problem, it'll fix this
problem too.
Jeremy.
Comment 6 Jeremy Allison 2005-10-12 15:53:19 UTC
I'm pretty sure this is a duplicate of bug #1828. I've just posted a patch for
this problem in 1828 and I'll be committing this into the tree - it should be
fixed for 3.0.21.
Jeremy.


*** This bug has been marked as a duplicate of 1828 ***