Bug 2626 - %m replaced by IP or empty
%m replaced by IP or empty
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: smbclient
3.0.14a
x86 Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-19 04:39 UTC by gerdfleischer
Modified: 2005-08-24 10:24 UTC (History)
0 users

See Also:


Attachments
ensure that calling_name is set to some value after parsing smb.conf (375 bytes, patch)
2005-04-19 07:01 UTC, Gerald (Jerry) Carter
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description gerdfleischer 2005-04-19 04:39:21 UTC
I have a message command in the form /usr/bin/foo %m ...
Since 3.0.12 to 3.0.14a %m is not replaced by the netbios name but by the IP of
the sender or is empty (3.0.14a).
Prior versions worked correctly in the same environment (SUSE 9.2).
name resolve order doesn't matter.
The problem seems to be on the sender side as in the direction
3.0.11 -> e.g. 3.0.12 it works correctly.
Comment 1 Gerald (Jerry) Carter 2005-04-19 06:11:12 UTC
Looks like you are correct.  It is a client side issue.
I've reproduced this here.


Comment 2 Gerald (Jerry) Carter 2005-04-19 07:01:26 UTC
Created attachment 1164 [details]
ensure that calling_name is set to some value after parsing smb.conf
Comment 3 Gerald (Jerry) Carter 2005-04-19 07:01:47 UTC
Thanks for reporting this.  The fix is attached.
Comment 4 gerdfleischer 2005-04-20 02:23:06 UTC
(In reply to comment #3)
> Thanks for reporting this.  The fix is attached.

Thanks, works with 3.0.15pre2.
Comment 5 Gerald (Jerry) Carter 2005-08-24 10:24:47 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.