Bug 2593 - libnss_wins.so (3.0.13) wont link on solaris 9/10
libnss_wins.so (3.0.13) wont link on solaris 9/10
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.13
Sparc Solaris
: P3 regression
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-11 10:17 UTC by Fredrik Lundholm
Modified: 2006-01-09 08:01 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fredrik Lundholm 2005-04-11 10:17:19 UTC
When I try to compile 3.0.13 on Solaris 9 or 10 with Sun CC it breaks:
(samba 3.0.7 compiled fine)
Is there a problem with Makefile.in?

 $ ./configure --prefix=/opt/csw
lunatic> gmake
Using FLAGS =  -g  -Iinclude -I/export/home/dol/src/samba-3.0.13/source/include
-I/export/home/dol/src/samba-3.0.13/source/ubiqx
-I/export/home/dol/src/samba-3.0.13/source/smbwrapper  -I. -D_LARGEFILE_SOURCE
-D_REENTRANT -D_FILE_OFFSET_BITS=64 -I/export/home/dol/src/samba-3.0.13/source
      LIBS = -lsendfile -lsec -lgen -lresolv -lsocket -lnsl
      LDSHFLAGS = -G -g  -lthread
      LDFLAGS = -lthread
Compiling dynconfig.po.c with -KPIC
Compiling lib/version.po.c with -KPIC
Linking nsswitch/libnss_wins.so
ld: fatal: file dynconfig.po.o: open failed: No such file or directory
ld: fatal: file lib/version.po.o: open failed: No such file or directory
ld: fatal: File processing errors. No output written to nsswitch/libnss_wins.so
gmake: *** [nsswitch/libnss_wins.so] Error 1
Comment 1 Fredrik Lundholm 2005-04-12 10:44:11 UTC
Seems to be a problem with Gmake 3.79.1 and Gmake 3.80.

Sun Distributed Make 7.5 2004/07/15 links without problems.
Comment 2 Tim Potter 2005-04-12 18:07:18 UTC
Are you using the same compiler for both runs?  I am guessing that one of your
tests is using gcc, and the other SUN cc.  Can you confirm?
Comment 3 Fredrik Lundholm 2005-04-13 00:32:40 UTC
(In reply to comment #2)
> Are you using the same compiler for both runs?  I am guessing that one of your
> tests is using gcc, and the other SUN cc.  Can you confirm?

I use the same Sun cc in both cases. (32 bit build) 
With the patch below gmake and dmake works on Solaris:
(dont know if this is correct or wanted,
got it from Thomas Glanzmann)
++++++++++++++++++
-- configure.orig	2004-02-13 09:59:53.087751000 -0500
+++ configure	2004-02-13 10:00:59.678426000 -0500
@@ -17738,7 +17738,6 @@
 				## ${CFLAGS} added for building 64-bit shared
 				## libs using Sun's Compiler
 				LDSHFLAGS="-G \${CFLAGS}"
-				PICSUFFIX="po.o"
 			fi
 
 cat >>confdefs.h <<\_ACEOF



Comment 4 Michael Kelleher 2006-01-09 07:51:29 UTC
This bug with Samba has been resolved ages ago and that particular compile problem no longer exists with newer versions of Samba.

Resolved -> Fixed?
Comment 5 Lars Müller 2006-01-09 08:01:35 UTC
Fredrik: Reopen if this issue isn't solved for you.

Michael : Thanks for the update.