Bug 2433 - sendfile support cannot be disabled in configure
sendfile support cannot be disabled in configure
Status: RESOLVED DUPLICATE of bug 2429
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.11
All Solaris
: P3 normal
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-09 07:38 UTC by Walter Haidinger
Modified: 2005-03-09 08:45 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Walter Haidinger 2005-03-09 07:38:24 UTC
./configure does not honor neither --without-sendfile-support nor
--with-sendfile-support=no.

From ./configure:

   37048 with_sendfile_support=yes
   37049 echo "$as_me:$LINENO: checking whether to check to support sendfile" >&5
   37050 echo $ECHO_N "checking whether to check to support sendfile... $ECHO_C" >&6
   37051 
   37052 # Check whether --with-sendfile-support or --without-sendfile-support
was given.
   37053 if test "${with_sendfile_support+set}" = set; then
   37054   withval="$with_sendfile_support"
   37055    case "$withval" in
   37056   yes)

Doesn't line 37048 override any option set on the commandline?

Regards, Walter
Comment 1 Walter Haidinger 2005-03-09 08:45:18 UTC

*** This bug has been marked as a duplicate of 2429 ***