Bug 2160 - nmbd crashes when compiled on fbsd with gcc3.4.2 (system default) with CFLAGS set to -Os
nmbd crashes when compiled on fbsd with gcc3.4.2 (system default) with CFLAGS...
Product: Samba 3.0
Classification: Unclassified
Component: nmbd
All FreeBSD
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2004-12-14 11:05 UTC by Roman Divacky
Modified: 2005-03-21 06:28 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Roman Divacky 2004-12-14 11:05:20 UTC
summary says it all... nmbd compiled in this way doesnt work more than hour.
would be nice to have this one solved...
Comment 1 Lars Müller 2004-12-14 11:23:36 UTC
This might be a duplicate of #1631.
Comment 2 Jeremy Allison 2004-12-14 11:30:19 UTC
So let me get this straight - when compiled with optimisations on nmbd crashes,
and with optimisations off it doesn't.

Tell me why this isn't a gcc compiler bug and why I can't close this bug
immediately as "not our bug" ?

Comment 3 Lars Müller 2004-12-14 11:43:26 UTC
Jeremy: You might close it.  But I'm not sure if this is the same problem as
from #1631.

Roman: Reopen if you think it's a primary Samba problem.
Comment 4 Roman Divacky 2004-12-15 01:46:03 UTC
this is what I got from ktracing the nmbd:
hudson10 ~# kdump | tail
 81726 nmbd     RET   write 15/0xf
 81726 nmbd     CALL  sigprocmask(0x3,0xbfbfdf10,0)
 81726 nmbd     RET   sigprocmask 0
 81726 nmbd     CALL  getpid
 81726 nmbd     RET   getpid 81726/0x13f3e
 81726 nmbd     CALL  kill(0x13f3e,0x6)
 81726 nmbd     RET   kill 0
 81726 nmbd     PSIG  SIGIOT caught handler=0x8099e28 mask=0xfffefedf code=0x0
 81726 nmbd     CALL  exit(0x1)
hudson10 ~#

I hope this will help...
Comment 5 Gerald (Jerry) Carter 2005-02-05 07:57:43 UTC
please retest against 3.0.11 and reopen if necessary.  Also reset 
the version if you reopen the bug report.  Thanks.
Comment 6 Roman Divacky 2005-02-07 09:01:42 UTC
I retested this on 3.0.11 and its still there...
Comment 7 Gerald (Jerry) Carter 2005-02-07 10:26:48 UTC
if ther compiler optimizations cause the crash it is a compiler bug.  Bot ours.
Comment 8 Roman Divacky 2005-03-21 06:28:55 UTC
seems to be solved in 3.0.12 (I am runing -Os samba more than 12 hours, before
it didnt survive 30 minutes)