Bug 2064 - Problem on Windows 98 machines opening a list of users and groups from Samba/LDAP domain
Problem on Windows 98 machines opening a list of users and groups from Samba/...
Status: RESOLVED WORKSFORME
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.12
x86 Windows 98
: P2 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
: 2066 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 12:55 UTC by Sergio Roberto Claser
Modified: 2013-09-02 11:30 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergio Roberto Claser 2004-11-18 12:55:32 UTC
when I try to share a directory on a Windows 98 workstation, I can't open a
users/groups list from Samba/LDAP 3.0.8 domain at the share dialog box. My
domain contains about 180 groups and 480 users. I think this is too large,
because when I try to do the same process using a Samba/LDAP 3.0.8 domain with a
short list of users/groups, everything works fine.
Analyzing with ethereal, I saw the server stopped sending information after a
few packets (2 or 3). The last packet seemed to be truncated. The tcpdump files
are available under request, in case they could be useful.
Comment 1 Gerald (Jerry) Carter 2004-11-24 10:19:11 UTC
*** Bug 2066 has been marked as a duplicate of this bug. ***
Comment 2 Gerald (Jerry) Carter 2005-02-07 13:24:47 UTC
please test 3.0.11 and reopen if this is not fixed.
Comment 3 Sergio Roberto Claser 2005-03-03 07:52:16 UTC
Jerry, the problem still remains.
Comment 4 Sergio Roberto Claser 2005-03-14 05:50:55 UTC
Jerry, the problem seems to be the same as that of BUG 1604. There is a lack of
sequence of the packages.
Comment 5 Gerald (Jerry) Carter 2005-03-14 08:36:16 UTC
so since BUG 1604 has been fixed in 3.0.12rc1, is this bug 
fixed then as well ?  I cannot reproduce any failures against
3.0.13pre1-SVN-build-5786 (basically the same as 3.0.12rc1).
Comment 6 Sergio Roberto Claser 2005-03-14 11:42:21 UTC
No, I tested 3.0.12PRE1 with Volker's patch for BUG 1604 and the Windows98 still
can't open a large users/groups list. When the list of users/groups fits in an
only package (1500 bytes), the list appears. But when more than one package is
necessary, it doesn't. I only want to compare the problem with BUG 1604, since
they are similar in the way that they do not follow the sequence of the initial
package. The package is repeated some times and stops.
Comment 7 Gerald (Jerry) Carter 2005-03-14 12:14:15 UTC
ok.  I understand now.  That's a big help.  Thanks.
Comment 8 Björn Jacke 2013-09-02 11:30:18 UTC
Haven't seen this problem for years. I guess this is fixed in the meantime? If not, please reopen. Thanks