Bug 1997 - Problem with German Chars in SWAT
Problem with German Chars in SWAT
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: SWAT
3.0.7
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-04 10:39 UTC by Reiner Klaproth
Modified: 2004-11-08 09:01 UTC (History)
0 users

See Also:


Attachments
new german translation file (12.28 KB, text/plain)
2004-11-04 10:43 UTC, Reiner Klaproth
no flags Details
Patch for german translation (8.99 KB, patch)
2004-11-04 22:08 UTC, Reiner Klaproth
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Reiner Klaproth 2004-11-04 10:39:47 UTC
The German translation in source/po/de.msg is broken.
This File contains special german chars ("Umlaute") in the translation for
web/swat.c -File. SWAT creates a HTML-3.2-Document and so this chars must
be recoded, for instance ä=ä and so on.
This mistake make SWAT unuseable in german language.
Comment 1 Reiner Klaproth 2004-11-04 10:43:09 UTC
Created attachment 754 [details]
new german translation file
Comment 2 Guenther Deschner 2004-11-04 13:39:07 UTC
Thanks for reporting, but this already has been fixed in samba 3.0.8pre2 by
Björn Jacke. You could try that prerelease or wait for 3.0.8.

Please reopen if it still does not work for you.
Comment 3 Reiner Klaproth 2004-11-04 22:06:05 UTC
This bug is NOT fixed in 3.0.8pre2
The problem is: SWAT use HTML-3.2. The german translation file by Björn Jacke
use the special german chars in UTF-8. This works for console programs such
smbpasswd and so on.
For the web frontend you can use UTF-8 only with HTML-4.0. This means, that one
way to fix the problem is using HTML-4.0 in SWAT. The other way is recoding the
chars to HTML-3.2.
The other problem: some of the translations are nuts. The translation does not
mean the right thing.
I attach a patch I used for samba-3.0.7 and 3.1.0
Comment 4 Reiner Klaproth 2004-11-04 22:08:06 UTC
Created attachment 757 [details]
Patch for german translation
Comment 5 Björn Jacke 2004-11-05 03:02:21 UTC
do you use a browser with utf-8 suppoert or ancient netscape 4.x versions? If
you use a utf-8 capable browser it will work probably. The used charset in html
is always utf-8 now and the msg files should also be utf-8 encoded, also
mentioned in the new docs. This is not an issue of html4 or html3. Of course if
you use entities you can work around broken utf-8 support in browsers but that's
not the way to go.
Comment 6 Reiner Klaproth 2004-11-05 08:53:08 UTC
The problem is always shown in
Mozilla -1.7
Internet Explorer 6
Konqueror 3.3

The entity-Version works fine with all browsers
Comment 7 Björn Jacke 2004-11-08 09:01:24 UTC
I double checked it worked correct also with IE. You should clean up your 
environment. You have most probably rotten swat include files on your disk.