Bug 1946 - Line with invalid domain user in Name Map file causes samba mapping error for user in previous line.
Line with invalid domain user in Name Map file causes samba mapping error for...
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Config Files
3.0.5
PA-RISC HP-UX
: P3 minor
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-18 18:19 UTC by Jeff Banjavcic
Modified: 2005-08-24 10:19 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Banjavcic 2004-10-18 18:20:00 UTC
Environment summary:

We recently upgraded to Samba 3.0.5 on an HP/UX 11i that is connected to
 Windows 2000 domain: BARANET.
We use samba only to share unix resources with W2K users, no printer shares are 
set up and no use of samba as PDC, BDC etc. All DC functions are provided by 
W2K. DNS used (no WINS) and NetBios over TCP/IP is disabled.


The following condition existed in the USERNAME MAP file:


blah = blah                CMT Valid user
kohwalsk = KohwalskiL      CMT This was a valid user on domain BARANET
auditor = ?                CMT This account previously removed from the domain
blah = blah                CMT Valid user

Note: in the above example, ? is the ASCII(13)

The errors below occured when user KohwalskiL tried to map to the unix share 
from Windows 2000 desktop.
When the invalid user id line (auditor = ?) was removed from the USERNAME MAP 
file, the error cleared up.
This condition of the file example above did not cause any mapping error on 
samba version < 3.

[2004/10/18 10:56:39, 0] auth/auth_domain.c:domain_client_validate(195) 
domain_client_validate: unable to validate password for user kohwalsk in domain
 BARANET to Domain controller \\STLDC001. Error was NT_STATUS_NO_SUCH_USER.

** Same error with debug=5 **

[2004/10/18 14:37:49, 5] auth/auth.c:check_ntlm_password(270)
  check_ntlm_password: winbind authentication for user [KohwalskiL] FAILED with
 error NT_STATUS_NO_SUCH_USER
[2004/10/18 14:37:49, 2] auth/auth.c:check_ntlm_password(310)
  check_ntlm_password:  Authentication for user [KohwalskiL] -> [KohwalskiL] 
FAILED with error NT_STATUS_NO_SUCH_USER
[2004/10/18 14:37:49, 5] auth/auth_util.c:free_user_info(1298)
  attempting to free (and zero) a user_info structure
Comment 1 Gerald (Jerry) Carter 2005-02-17 09:47:38 UTC
I cannot reproduce this locally.  Would you retest 
against 3.0.11 and reopen if the bug still exists ?
There were some username map changes in 3.0.8.  Make sure 
to read the WHATSNEW.  Thanks.
Comment 2 Gerald (Jerry) Carter 2005-08-24 10:19:22 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.