Bug 1808 - ambiguosity #3 in man smb.conf, inherit acls
ambiguosity #3 in man smb.conf, inherit acls
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: Docs
3.0.6
All All
: P3 normal
: none
Assigned To: Jelmer Vernooij
Samba QA Contact
:
: 1807 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-22 08:28 UTC by Clock
Modified: 2004-12-07 14:36 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Clock 2004-09-22 08:28:34 UTC
"This  parameter can be used to ensure that if default acls exist
              on parent directories, they are always honored when  creating  a
              subdirectory.  The default behavior is to use the mode specified
              when creating the directory."

The problem is in the sentence "The default behavior is to use the mode specified
when creating the directory". It can mean two semantically AND syntactically
different things:
1) The defaut behaviour when creating the directory is to use the specified mode
2) The default behaviour when creating a subdirectory is to use the mode that
was specified when the parent directory was created.
Comment 1 Jelmer Vernooij 2004-12-07 14:35:27 UTC
This obviously refers to the subdirectory. Semantically, there /really/ is no
other meaning possible.
Comment 2 Jelmer Vernooij 2004-12-07 14:36:06 UTC
*** Bug 1807 has been marked as a duplicate of this bug. ***