Bug 1720 - cannot join a w2k-client to a Samba-PDC
cannot join a w2k-client to a Samba-PDC
Status: RESOLVED DUPLICATE of bug 1631
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
3.0.6
All Windows 2000
: P3 major
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-04 03:52 UTC by Sven Strickroth
Modified: 2004-10-19 14:01 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Strickroth 2004-09-04 03:52:45 UTC
After upgrading to 3.0.6 I cannot join w2k-clients to my domain, but 
authenticating against to pdc is working.

[2004/09/04 12:31:01, 0] rpc_server/srv_samr.c:api_samr_set_userinfo(786)
  api_samr_set_userinfo: Unable to unmarshall SAMR_Q_SET_USERINFO.
[2004/09/04 12:31:01, 0] libsmb/smbencrypt.c:decode_pw_buffer(539)
  decode_pw_buffer: incorrect password length (2002802281).
[2004/09/04 12:31:01, 0] libsmb/smbencrypt.c:decode_pw_buffer(540)
  decode_pw_buffer: check that 'encrypt passwords = yes'


[2004/09/04 12:33:30, 0] rpc_server/srv_samr.c:api_samr_set_userinfo(786)
  api_samr_set_userinfo: Unable to unmarshall SAMR_Q_SET_USERINFO.
[2004/09/04 12:33:30, 0] libsmb/smbencrypt.c:decode_pw_buffer(539)
  decode_pw_buffer: incorrect password length (-1092641478).
[2004/09/04 12:33:30, 0] libsmb/smbencrypt.c:decode_pw_buffer(540)
  decode_pw_buffer: check that 'encrypt passwords = yes'

my smb.conf:
[global]
        dos charset = 850
        unix charset = ISO8859-1
        workgroup = GYM-OHA
        server string = Samba Server %v
        passwd program = /usr/bin/passwd %u
        passwd chat = *New*UNIX*password* %n\n *Re*ype*new*UNIX*password* %
n\n*passwd:*all*authentication*tokens*updated*successfully*
        username map = /etc/samba/smbusers
        password level = 8
        unix password sync = Yes
        log file = /var/log/samba/log.%m
        max log size = 50
        name resolve order = wins host lmhosts bcast
        time server = Yes
        client signing = No
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192 
IPTOS_LOWDELAY
        load printers = No
        mangle prefix = 5
        logon script = %U.bat
        logon path = \\%N\%U\NTProfile
        logon drive = U:
        domain logons = Yes
        os level = 250
        lm announce = Yes
        domain master = Yes
        dns proxy = No
        wins proxy = Yes
        wins support = Yes
        utmp = Yes
        admin users = @administratoren
Comment 1 Sven Strickroth 2004-09-20 09:14:26 UTC
Compiling Samba 3.0.7 with gcc-3.4.1 solves this problem. The "defect" samba 
was compiled with gcc-3.3.2 (but I had never problems with that gcc before). -> 
Very mysterious :(.

See bug 1771
Comment 2 Michael Dance 2004-09-23 03:52:42 UTC
I also have this problem after deploying samba-3.0.7-1_rh9.i386.rpm from
samba.org (to correct a file locking problem introduced in 3.0.6). Is there a
new build planned to resolve this problem?

Thanks in advance
Comment 3 Gerald (Jerry) Carter 2004-09-23 04:57:34 UTC
Sven,  this is probably a duplicate of BUG 1631.

Michael, the RH9 RPM was built with 
gcc version 3.2.2 20030222 (Red Hat Linux 3.2.2-5)
so I doubt you are seeing the same bug.
Comment 4 Sven Strickroth 2004-09-23 07:52:25 UTC
I suppose it is a duplicate, too. See my buildlog attachment 672 [details], I built with -
O2, too. I will try to test this and compile without -O2...
Comment 5 Sven Strickroth 2004-10-19 14:01:10 UTC
It's an dublicate. Help for rpms (spec-files):
%define gcc331 %(gcc -dumpversion|awk '{if ($1>3.3 && $1 < 3.4) print 1; else 
print 0}')
%if %gcc331
CFLAGS=`echo "$CFLAGS"|sed -e 's/-O2/-O/g'`
%endif

*** This bug has been marked as a duplicate of 1631 ***