Bug 1555 - Problem with mangled map
Problem with mangled map
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.4
x86 All
: P3 major
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-23 07:38 UTC by Michael Gross
Modified: 2005-05-10 08:46 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Gross 2004-07-23 07:38:05 UTC
I am using a Samba 3.0.4-1.27 on a SuSe 9.1 to share files on the network for
several Windows boxen (Win98, Win2k).

Everything else works just fine, but:

I wanted to use the "mangeld map" option, but it doesn't seem to work correctly
(or different?) with this version of samba (this option works properly with a
samba 2.0.3 on a HP-UX 10.20):

I use mangled map = (*.txt *.tst) (just an example) and the *.txt files appear
as *.tst on my windows box, but when I try to open the file I get the error message:

"The file /M:/test.tst cannot be found. Please check the location and try again."

This problem appears on different Windows Clients (Win2k & Win98)

If I delete the mangled map option, Windows shows the file "test.txt" an I can
access it.

Greetings Michael
Comment 1 Michael Gross 2004-07-27 00:39:33 UTC
The same error occurs with different versions of samba server (3.04, 3.05) and
with different samba clients. I tried a samba3-client (3.0.5-1) on a SuSe 9.0
and I can't open a file with a mangled filename (via mangled map), too.

-> The bug is not related to the OS of the samba client
Comment 2 Dave Abrahams 2004-09-05 19:53:48 UTC
I'd like to raise the priority on this one, since this feature seems to be 
widely documented but almost never used.  I can't find anyone else on the web 
who's using it.  For me, it's broken in the same way with samba-2.2.7a-7.9.0 
and samba-3.0.6-1: I have to set 

  mangled names = no 

in order to see any effect at all, and then the filenames show up beautifully 
translated in directory listings but I can't open them at all from a Windows 
XP Pro client.  My translations are:

  mangled map = (*"* *''*) (*?* *&*)

Has anyone really tested this feature?

Dave Abrahams
dave@boost-consulting.com
Comment 3 TAKAHASHI Motonobu 2004-12-30 08:50:04 UTC
I found the same problem at Samba 3.0.10.
This bug occurs because reversible mapping is not done.
When a .tst file is accessed from Windows client, Samba should map it to .txt 
file, but currently Samba does not do anything.
 
Comment 4 Gerald (Jerry) Carter 2005-02-08 07:19:09 UTC
mangled map should be depreacted I think.  It has been suffereing 
from bit rot for a while.  This will be a no fix I'm pretty sure.
I'll talk to jeremy about it first.
Comment 5 Gerald (Jerry) Carter 2005-05-10 08:46:33 UTC
deprecated parameter