Bug 1533 - smbd sends 1200/sec ldap queries for invalid uid
smbd sends 1200/sec ldap queries for invalid uid
Status: RESOLVED DUPLICATE of bug 1478
Product: Samba 3.0
Classification: Unclassified
Component: File Services
All Windows XP
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2004-07-14 21:23 UTC by Warwick Smith
Modified: 2004-07-16 04:20 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Warwick Smith 2004-07-14 21:23:07 UTC
We are using OpenLDAP as a password backend and have found every so often that
the slapd process runs away.  This was traced down to repeated queries (around
1200 per second) for an invalid uid from an smbd process.

An example slapd log entry:
Jul 15 13:25:19 myhost slapd[25634]: conn=3 op=369 SRCH
base="ou=Users,dc=example,dc=com" scope=1

More tracking has found that this uid (testuser) was listed in a memberUid
attribute of a samba ldap group.  

This is of course a problem with invalid data in our ldap database (should only
have valid users listed), but I think the smbd should accept the first "nope, no
such user" response and get on with other things :)

We are okay now (we've done some tidying), but I'm hoping that someone will have
a look at the code so I can sleep easier in the future!
Comment 1 Guenther Deschner 2004-07-16 04:13:08 UTC
Should be fixed with

Could you please try again with samba3.0.5rc1 ?
Comment 2 Guenther Deschner 2004-07-16 04:20:56 UTC

*** This bug has been marked as a duplicate of 1478 ***