Bug 14633 - IPV6 DNS reply not transmitted to client (samba 4.4.16)
Summary: IPV6 DNS reply not transmitted to client (samba 4.4.16)
Alias: None
Product: Samba 4.1 and newer
Classification: Unclassified
Component: DNS server (internal) (show other bugs)
Version: unspecified
Hardware: All All
: P5 major (vote)
Target Milestone: ---
Assignee: Samba QA Contact
QA Contact: Samba QA Contact
Depends on:
Reported: 2021-02-05 15:54 UTC by step
Modified: 2021-02-26 12:56 UTC (History)
0 users

See Also:

samba dns log (13.71 KB, text/plain)
2021-02-05 15:54 UTC, step
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description step 2021-02-05 15:54:38 UTC
Created attachment 16434 [details]
samba dns log

My ISP force to migrate to IPV6, so i gave a static IPV6 adress to my samba nas (AD controller).

I tried a nslookup using "server" directive with its IPV6 address: timeout.
Using IPV4 it worked.

Using samba log, i can see that the query is received and forwarded (non authoritative)using IPV6. We get an answer to the forwarding request(with A and AAAA correct values). But nothing seems to go back to the client.

I checked a firewall issue, but with firewall disabled (same problem).
I used wireshark client side : query but no answer.

I attached the log for the IPV6 request of google.com using log level 8 in dns facility.
Comment 1 Björn Jacke 2021-02-26 12:55:07 UTC
"host -t aaaa www.google.fr samba-dc.example.com" works well for me. If you still see a different problem, please supply more detailled information how to reproduce the problem.
Comment 2 Björn Jacke 2021-02-26 12:56:20 UTC
and please use a supported samba release like current 4.11/4.12/4.13 release, 4.4 is out of support since a long time.