Bug 13732 - dpkg error unconfigured when upgrading winbind
dpkg error unconfigured when upgrading winbind
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Winbind
4.7.6
x64 Linux
: P5 normal
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-12-29 22:18 UTC by Patrick Headley
Modified: 2018-12-29 22:36 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Headley 2018-12-29 22:18:35 UTC
I created a new post a couples weeks back explaining that Samba 4.7.6 running on Ubuntu 18.04.1 LTS with Linux 4.15.0-43-generic wouldn't upgrade winbind. The error text said that dpkg could not run the post installation tasks; leaving winbind unconfigured. I'm using Aptitude to perform an upgrade. Unfortunately, I cannot find the post.

In that post I mentioned the error message details. At that time I thought that it was a problem caused by winbind running as a child process of the Samba AD DC.

Today, I worked on the issue again and got it resolved. Since it's resolved I no longer have the error text. Turns out it was a problem with dpkg and not Samba or Winbind. I found some instructions on https://blog.csdn.net/yao201606/article/details/76208644 that resolved the issue. This SAMBA AD DC is several years old. The way it looks to me (I'm not expert on this) is that the installation of the stand-alone version of winbind got corrupted. Probably at the time winbind became a child process of Samba.

I'm creating this post in order to show the steps that resolved the issue. The steps are:

1、sudo mv /var/lib/dpkg/info/ /var/lib/dpkg/info_old/
2、sudo mkdir /var/lib/dpkg/info/
3、sudo apt-get update
4、sudo apt-get -f install

Running these steps uninstalled winbind. After running the instructions I rebooted the DC. Samba still works. Ran an upgrade using Aptitude. Works and winbind was not reinstalled.

I only have the one SAMBA AD DC with the problem so don't know if the solution will work for anyone else.
Comment 1 Patrick Headley 2018-12-29 22:36:23 UTC
My apologies. Bug #13730 is not the related bug report that I referred to in the description. Still can't find the original post. Even so, the problem described in this post is resolved.