Bug 1338 - smbclient -L netbiosname doesn't display the Arabic shares folder names nor the Arabic comments on the English shares.
smbclient -L netbiosname doesn't display the Arabic shares folder names nor t...
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: Extended Characters
3.0.2a
Other Linux
: P3 major
: none
Assigned To: Alexander Bokovoy
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-10 08:01 UTC by Munzir Taha
Modified: 2010-04-26 03:32 UTC (History)
0 users

See Also:


Attachments
The smbclient -L //student204 output when dos charset = CP850 (27.14 KB, application/pdf)
2004-05-10 08:07 UTC, Munzir Taha
no flags Details
The tcpdump output (9.03 KB, application/octet-stream)
2004-05-10 08:08 UTC, Munzir Taha
no flags Details
A tcpdump 'host 192.168.101.105 and (port 137 or port 138 or port 139 or port 445)' (7.27 KB, application/octet-stream)
2004-05-16 15:09 UTC, Munzir Taha
no flags Details
My smb.conf file (21.54 KB, text/plain)
2004-05-16 15:21 UTC, Munzir Taha
no flags Details
The relevant log files compressed (4.77 KB, application/x-tbz)
2004-05-18 09:16 UTC, Munzir Taha
no flags Details
CP720 encoding page in the same format as those in /usr/share/i18n/charmaps/ (11.95 KB, text/plain)
2004-07-29 08:29 UTC, Pablo Saratxaga
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Munzir Taha 2004-05-10 08:01:15 UTC
smbclient servicename works great and I can ls any Arabic file names but  
smbclient -L <netbios name> doesn't display the Arabic shares folder names nor the Arabic 
comments on the English shares. 
 
To debug (per  Alexander Bokovoy request): 
I am attaching the network trace of the session got with Ethereal and tcpdump(tcpdump -s 10000 -w 
trace-file.pcap) and my smb.conf file. 
The pdf attached shows my screen when 
$ testparm -v |grep charset 
gives 
        dos charset = CP850 
        unix charset = UTF-8 
        display charset = LOCALE 
when I changed the dos charset to UTF-8 the Arabic letters appear as squares (I will attach another 
network trace if you asked for it) 
 
I will attach the samba log with log level 10 later.
Comment 1 Munzir Taha 2004-05-10 08:07:47 UTC
Created attachment 502 [details]
The smbclient -L //student204 output when dos charset = CP850
Comment 2 Munzir Taha 2004-05-10 08:08:24 UTC
Created attachment 503 [details]
The tcpdump output
Comment 3 Munzir Taha 2004-05-16 15:09:57 UTC
Created attachment 513 [details]
A tcpdump 'host 192.168.101.105 and (port 137 or port 138 or port 139 or port 445)'

The smb.conf file is set to dos charset = UTF-8 this time
Comment 4 Munzir Taha 2004-05-16 15:21:20 UTC
Created attachment 514 [details]
My smb.conf file
Comment 5 Munzir Taha 2004-05-18 09:16:27 UTC
Created attachment 518 [details]
The relevant log files compressed
Comment 6 Munzir Taha 2004-05-18 09:16:44 UTC
Alexander, please tell me if you need any more info 
Comment 7 Alexander Bokovoy 2004-05-18 09:58:44 UTC
No need for more info so far, thank you for all provided logs and snippets. I'll
be able to look at those only starting next week or so, please wait until May, 28th.
Comment 8 Munzir Taha 2004-06-04 03:17:24 UTC
 Alexander, the date has passed ;) I hope you have done something. 
Comment 9 SATOH Fumiyasu 2004-07-12 20:33:02 UTC
In the command prompt (or MS-DOS prompt on Windows 9x/Me) on Windows
client, please type a command ``chcp''. This command shows you
a ``Code Page'' number. This is your best ``dos charset'' value.
If chcp shows ``850'', your ``doc charset'' value is ``CP850''.

By the way, what locale are you using on UNIX shell?
If your locale setting is wrong, smbclient cannot print
strings well.
Comment 10 Munzir Taha 2004-07-19 14:42:05 UTC
In my windows 2000 and XP, chcp shows 720 so I set dos charset to CP720 and 
get those errors upon using smbclient: 
 
Conversion from UCS-2LE to CP720 not supported 
Conversion from UTF-8 to CP720 not supported 
Conversion from UTF-8 to CP720 not supported 
Conversion from CP720 to UCS-2LE not supported 
Conversion from CP720 to UTF-8 not supported 
Conversion from CP720 to UTF-8 not supported 
Conversion from CP720 to UTF8 not supported 
Conversion from UTF8 to CP720 not supported 
... 
convert_string_internal: Conversion not supported. 
 
I also tried 720 without the CP and almost the same problem. I checked iconv 
but couldn't find this 720 encoding! 
Comment 11 Pablo Saratxaga 2004-07-29 08:29:20 UTC
Created attachment 588 [details]
CP720 encoding page in the same format as those in /usr/share/i18n/charmaps/
Comment 12 Pablo Saratxaga 2004-07-29 08:37:43 UTC
It seems the problem is due to the lack of the CP720 code set.

Now, I don't know samba internals; would it be enough to add it to glibc;
or does Samba needs to be made aware of it somehow?

(attached an IBM720 file I just write; it isn't enough to make iconv
recognize it, a patch to glibc is needed too)
Comment 13 Alexander Bokovoy 2005-01-13 06:01:04 UTC
Adding it to glibc would be enough, on Linux samba does utilise system's iconv
implementation.
Comment 14 Gerald (Jerry) Carter 2006-04-08 11:54:50 UTC
please reopen if the bug still exists in a current release.
Comment 15 Munzir Taha 2006-04-16 15:58:33 UTC
I just checked using 3.0.21c in ubuntu dapper drake and the bug is still valid.
Comment 16 Stefan Metzmacher 2010-04-26 03:32:21 UTC
If it's still broken in 3.5, please reopen.
3.0 isn't supported anymore.