Bug 1299 - Wrong Files Displayed
Wrong Files Displayed
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.2a
All Linux
: P2 critical
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-28 00:56 UTC by Michael
Modified: 2005-08-24 10:23 UTC (History)
0 users

See Also:


Attachments
Shell-Script for creating a directory containing the same file-names! (922.61 KB, text/plain)
2004-04-28 03:05 UTC, Michael
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2004-04-28 00:56:21 UTC
In one directory shared by Samba on SuSE 9.0 there are more than 40000 PDF-files.
All of them with a name-schema like 12345600a2.pdf. 

When typing the command:

> smbclient \\\\server\\pdf -U kuznik
Password:
Domain=[DOM] OS=[Unix] Server=[Samba 3.0.2a-SuSE]
smb: \> cd MH
smb: \MH\> ls 8641*
  84756300a3.pdf                  A   106348  Thu Apr 22 16:35:44 2004

                37157 blocks of size 1048576. 6900 blocks available
smb: \MH\>

You'll see this is wrong because there isn't really a file begins with 8641!
When I use the cmd of w2k you become the same!
When typing a 2 digit number like 73* or 82* it's the also same! 

smb: \MH\> ls 73*
  73070000.pdf                    A    39302  Thu Apr 22 16:25:49 2004
  73066000.pdf                    A    39302  Thu Apr 22 16:25:48 2004
  71134700a3.pdf                  A   134871  Thu Apr 22 16:25:47 2004
  73061700.pdf                    A    39302  Thu Apr 22 16:25:48 2004
  74162800a2.pdf                  A   167681  Thu Apr 22 16:25:49 2004
  74265300a2.pdf                  A   174921  Thu Apr 22 16:25:55 2004
  70247300a2.pdf                  A   873184  Thu Apr 22 16:25:46 2004
  74101100a2.pdf                  A    92476  Thu Apr 22 16:25:49 2004
  73000300.pdf                    A    39302  Thu Apr 22 16:25:48 2004
  70125200a4.pdf                  A   110801  Thu Apr 22 16:25:46 2004
  73010800a3.pdf                  A    72727  Thu Apr 22 16:25:48 2004
  73001000.pdf                    A    39302  Thu Apr 22 16:25:48 2004
  70404300a4.pdf                  A    42099  Thu Apr 22 16:25:47 2004
  73034400a3.pdf                  A   301650  Thu Apr 22 16:25:48 2004
  73001100.pdf                    A    39302  Thu Apr 22 16:25:48 2004

                37157 blocks of size 1048576. 6900 blocks available
smb: \MH\>

When typing a 5 or more digit-number it seems to be OK. (Like 12345* )

The Server I noticed that the first time is configured as an LDAP-PDC.
I then tried it on a new SuSE9.1 with Samba 3.0.2a with a minimal config
an there it is the same. The same Directory shared with Samba 2.2.5 or 2.2.7
works fine.
But I can't reproduce the Bug #1258.

I think this is a relative important Bug because of the possibilty to loose data!
Comment 1 Michael 2004-04-28 03:05:15 UTC
Created attachment 479 [details]
Shell-Script for creating a directory containing the same file-names!

The script creates the diretory /tmp/test. In this directory more than 40000
files would be created. They are the same as in our directory.
Now you must share this directory with samba and connect to the share with
smbclient or use a cmd from w2k. Now please type in 73* and you will see it! I
hope ;)
Comment 2 Gerald (Jerry) Carter 2005-04-20 06:46:43 UTC
please retest against 3.0.14a after ensuring that 
'mangling method = hash2' has been set in smb.conf.
Thanks.
Comment 3 Gerald (Jerry) Carter 2005-08-24 10:23:45 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.