Bug 1295 - A folder whose name is in Arabic characters can't be smbmounted
A folder whose name is in Arabic characters can't be smbmounted
Product: Samba 3.0
Classification: Unclassified
Component: Extended Characters
Other Linux
: P3 major
: none
Assigned To: Alexander Bokovoy
Depends on:
  Show dependency treegraph
Reported: 2004-04-26 15:16 UTC by Munzir Taha
Modified: 2005-08-24 10:18 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Munzir Taha 2004-04-26 15:16:24 UTC
I have some shared folders with Arabic names in a Windows XP computers. I 
tried to access them using smbclient and smbmount from a linux PC but failed 
whatever option I've tried. Changing the dos charset, unix charset, display 
charset to all the possible values also failed. Is this a known issue. Isn't 
Samba 3 supports Unicode which means this should be possible.
Comment 1 Alexander Bokovoy 2004-04-26 21:56:31 UTC
Can you provide more information about your configuration (including smb.conf
and debug log for smbclient)? smbfs doesn't use Unicode on wire (it is
independent kernel module), while smbclient should. Also, you may try cifsfs
which supports unicode too.
Comment 2 Munzir Taha 2004-04-28 05:18:22 UTC
I am deeply sorry for saying smbclient doesn't work. I tried it again and it worked. smbmount is 
the one that doesn't work. This affects GUI programs like Smb4k, LinNeighborhood. I can see 
arabic letters by mounting Arabic shares whether using CLI or GUI. Any more info? 
Comment 3 Alexander Bokovoy 2004-04-28 08:46:29 UTC
I'm assuming you wanted to say "I can't see arabic letters"?
Make sure your kernel has charset module for Arabic -- both the charset which is
used as 'dos charset' and for your local unix charset.

smbfs is external project, unrelated to Samba. It is developed outside Samba
Team. Samba just contains small user-space helpers needed to get smbfs connected
to a server. Everything else is handled within kernel. Therefore, charset
conversion is done there too and you need to make sure you have proper kernel
charset modules installed (and configured -- as options to mount command).
Comment 4 Munzir Taha 2004-04-28 15:25:33 UTC
Yes, s/can/can't. 
Today I tried mount.cifs and it works fine. So, smbmount doesn't do the job but mount.cifs 
works. Will you please tell me why then we still need smbmount. They both comes in 
samba-client-3.0.2a, isn't it redundant? 
Also, whether it's right to file a bug to smb4k and LinNeighborhood to use cifs instead of smb. 
Thanks a lot for your help 
Comment 5 Munzir Taha 2004-04-29 08:15:41 UTC
Regarding the kernel module: 
If you mean nls_utf8, it's already compiled and loaded. 
[root at localhost emunzir]# lsmod |grep utf 
nls_utf8                1920  2 
I am sorry if this discussion shouldn't be here. Feel free to close the bug now. 
Comment 6 Alexander Bokovoy 2004-05-01 06:36:16 UTC
Close at it is more kernel configuration related.
Comment 7 Munzir Taha 2004-05-01 14:15:36 UTC
Ok! for the kernel related configuration I will check it on another place but I notice a problem in 
smbclient itself. 
smbclient servicename 
works great and I can ls any Arabic file names but 
smbclient -L <netbios name> 
doesn't display the Arabic shares nor the Arabic comments on the English shares. Do I need to 
file another bug? 
Comment 8 Alexander Bokovoy 2004-05-01 15:05:33 UTC
Yes. Please attach to it following information:
1. Samba log with loglevel 10
2. Network trace of the session got with Ethereal or tcpdump. In latter case use
'tcpdump -s 10000 -w trace-file.pcap' to store the data into file.

Please limit your tcpdump or Ethereal filter to CIFS protocols (ports 137-139,
445, tcp/udp) between your client and server and use temprorary user/anonymous
access to not publish sensitive details about your environment.

3. Attach smb.conf.
Comment 9 Gerald (Jerry) Carter 2005-08-24 10:18:51 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.