Bug 12820 - rsync always try change owner and group of symlink in --fake-super mode
rsync always try change owner and group of symlink in --fake-super mode
Status: NEW
Product: rsync
Classification: Unclassified
Component: core
3.0.9
All All
: P5 normal
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-05 21:32 UTC by Pavel Alexeev
Modified: 2017-06-05 21:32 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Alexeev 2017-06-05 21:32:04 UTC
Hello.

I long time discover strange to me behavior. If I add --fake-super
option on both sides rsync start always set owner and group of symlink.
What interesting there no error, but it done each time as it has been
changed.

Simple reproduce:
$ mkdir rsync.symlinks
$ echo 'file content' > rsync.symlinks/file.itself
$ ln -s file.itself rsync.symlinks/file.symlink

Then try to transfer it on remote host:
$ rsync -apr --links --itemize-changes --fake-super -M--fake-super
rsync.symlinks [hidden email]:~/temp/rsync.symlinks
cd+++++++++ rsync.symlinks/
<f+++++++++ rsync.symlinks/file.itself
cL+++++++++ rsync.symlinks/file.symlink -> file.itself

And again:
.L....og... rsync.symlinks/file.symlink -> file.itself


I had tried use --rsync-path="rsync --fake-super" instead of
-M--fake-super what unsurprisingly give me same result:
$ rsync -apr --links --itemize-changes --fake-super --rsync-path="rsync
--fake-super" rsync.symlinks
[hidden email]:~/temp/rsync.symlinks
.L....og... rsync.symlinks/file.symlink -> file.itself


Please note all symlinks correct:
$ LANG=en_US.utf-8 ls -l rsync.symlinks
total 4
-rw-rw-r--. 1 pasha pasha 13 Oct 11 06:10 file.itself
lrwxrwxrwx. 1 pasha pasha 11 Oct 11 06:11 file.symlink -> file.itself

$ cat rsync.symlinks/file.symlink
file content

It also correct on receiver side.


P.S. Asked long time ago in ML - http://samba.2283325.n4.nabble.com/rsync-always-try-change-owner-and-group-of-symlink-in-fake-super-mode-td4692664.html