Bug 12813 - dns_name_equal doing OOB read
dns_name_equal doing OOB read
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: DNS server
4.5.0
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-01 02:40 UTC by Garming Sam
Modified: 2017-07-14 08:12 UTC (History)
2 users (show)

See Also:


Attachments
patch for 4.6 cherry-picked from master (1.39 KB, patch)
2017-06-27 18:22 UTC, Andrew Bartlett
metze: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Garming Sam 2017-06-01 02:40:36 UTC
Many autobuilds have been flakey since the introduction of the dnsserver and dns samba-tool tests. The cause has been an 1 byte out of bounds read comparing with '.'. This would fail intermittently because every now and again when these two would match.
Comment 1 Andrew Bartlett 2017-06-27 18:22:36 UTC
Created attachment 13316 [details]
patch for 4.6 cherry-picked from master

Fixed in master with 5ccfd38156ddf2435df15600638cde8ed020958f, please apply to 4.6
Comment 2 Stefan Metzmacher 2017-07-13 04:57:06 UTC
Comment on attachment 13316 [details]
patch for 4.6 cherry-picked from master

Pushed to autobuild-v4-6-test
Comment 3 Stefan Metzmacher 2017-07-14 08:12:50 UTC
(In reply to Stefan Metzmacher from comment #2)

Pushed to v4-6-test