Bug 12697 - CTDB can spin hard on revoking readonly delegations if a node becomes disconnected
CTDB can spin hard on revoking readonly delegations if a node becomes disconn...
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: CTDB
4.6.0
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-16 01:13 UTC by Amitay Isaacs
Modified: 2017-06-02 07:49 UTC (History)
4 users (show)

See Also:


Attachments
Patch for v4-5, v4-6 (2.12 KB, patch)
2017-03-20 00:54 UTC, Amitay Isaacs
martins: review+
Details
Patches for v4-5, v4-6 (7.52 KB, patch)
2017-05-25 02:18 UTC, Amitay Isaacs
martins: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Amitay Isaacs 2017-03-16 01:13:54 UTC
If revoking of readonly delegations fail, CTDB reschedules a retry immediately.  If a node becomes disconnected during this time, CTDB is stuck retrying revoke.
Comment 1 Amitay Isaacs 2017-03-20 00:54:21 UTC
Created attachment 13088 [details]
Patch for v4-5, v4-6
Comment 2 Martin Schwenke 2017-03-20 03:12:13 UTC
Hi Karolin,

This is ready for 4.5 and 4.6.

Thanks...
Comment 3 Karolin Seeger 2017-03-23 11:51:48 UTC
(In reply to Martin Schwenke from comment #2)
Pushed to autobuild-v4-{6,5}-test.
Comment 4 Karolin Seeger 2017-03-28 10:14:25 UTC
Pushed to both branches.
Closing out bug report.

Thanks!
Comment 5 Amitay Isaacs 2017-05-18 02:12:00 UTC
This fix causes a regression starving write requests.  

Since all the requests are deferred on that node, a read-only request from a different node can cause read-only delegations to be recreated.  Thus, wasting the revoke effort and write request has to re-do the revoke of readonly delegations.
Comment 6 Amitay Isaacs 2017-05-25 02:18:47 UTC
Created attachment 13236 [details]
Patches for v4-5, v4-6
Comment 7 Martin Schwenke 2017-05-25 02:27:55 UTC
Hi Karolin,

This is ready for 4.5 and 4.6.

Thanks...
Comment 8 Karolin Seeger 2017-05-30 10:03:30 UTC
(In reply to Martin Schwenke from comment #7)
Pushed to autobuild-v4-{5,6}-test.
Comment 9 Karolin Seeger 2017-06-02 07:49:44 UTC
(In reply to Karolin Seeger from comment #8)
Pushed to both branches.
Closing out bug report.

Thanks!