Bug 12146 - ../source4/heimdal/lib/gssapi/gssapi/gssapi_spnego.h:41:1: fatal error: unknown type name 'GSSAPI_CPP_START'
../source4/heimdal/lib/gssapi/gssapi/gssapi_spnego.h:41:1: fatal error: unkno...
Status: RESOLVED DUPLICATE of bug 12142
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Build
x64 Mac OS X
: P5 normal
: ---
Assigned To: Samba QA Contact
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2016-08-12 15:54 UTC by s3
Modified: 2016-08-15 09:56 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description s3 2016-08-12 15:54:52 UTC
The option "--with-system-mitkrb5" returns the following

ERROR: MIT krb5 build requires at least 1.9.0. Kerberos 5 release 1.7-prerelease is found and cannot be used
ERROR: You may try to build with embedded Heimdal Kerebros by not specifying --with-system-mitkrb5

Compiling without the above option returns the following

[ 573/3582] Compiling lib/addns/dnsrecord.c
In file included from ../lib/addns/dnsrecord.c:24:
In file included from ../lib/addns/dns.h:31:
In file included from ../lib/replace/system/gssapi.h:47:
../source4/heimdal/lib/gssapi/gssapi/gssapi_spnego.h:41:1: fatal error: unknown type name 'GSSAPI_CPP_START'
1 error generated.
Waf: Leaving directory `/Volumes/home/opt/src/samba-4.4.5/bin'
Build failed:  -> task failed (err #1): 
        {task: cc dnsrecord.c -> dnsrecord_1.o}
make: *** [all] Error 1
Comment 1 s3 2016-08-15 09:56:14 UTC

*** This bug has been marked as a duplicate of bug 12142 ***