Bug 1204 - problems with force user
problems with force user
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.2a
All FreeBSD
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-22 05:05 UTC by Manoel Gonçalves
Modified: 2005-08-24 10:20 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Manoel Gonçalves 2004-03-22 05:05:36 UTC
Running Samba3.0.2a as PDC i have a share like this:

[compras]
   path = /home/compras
   create mask = 0771
   directory mask = 0771
   force user = nobody
   force group = compras
   valid users = @compras

All the files and directories in this share are like this:
-rwxrwx--x   1 nobody  compras    112K Mar 20 10:37 order603.rtf

When a user member of the group "compras" logs in using win98SE and access the 
share all files are there. But if he press F5 (refresh) or close the file 
browser and open it again, some files ramdomly disappear. The problem is solved 
when i comment the line "force user = nobody".

Please let me know if you need more info.
Comment 1 Gerald (Jerry) Carter 2004-03-22 06:33:12 UTC
I cannot reproduce this locally using your config 
options.  Approximately how many files are we walking 
about here?
Comment 2 Manoel Gonçalves 2004-03-22 07:35:05 UTC
The share has 2515 files in 184 directories. I saw about 10 files and 2 or 3 
directories disappearing.
I found that this files were under non-english caracters directories, 
like "Solicitações de Cotação". I can't confirm right now if it only occurs in 
these cases, but it seems to be.
Comment 3 Gerald (Jerry) Carter 2004-05-27 03:23:31 UTC
please test 3.05.pre1 and let me know.  There
has been a lot of work in this area.
Comment 4 Gerald (Jerry) Carter 2005-02-11 07:33:41 UTC
closing as fixed.  
Comment 5 Gerald (Jerry) Carter 2005-02-11 07:33:56 UTC
closing again (goofed last change).
Comment 6 Gerald (Jerry) Carter 2005-08-24 10:20:40 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.