Bug 11903 - 'net -k ads join' fails
'net -k ads join' fails
Status: RESOLVED DUPLICATE of bug 11858
Product: Samba 4.1 and newer
Classification: Unclassified
Component: DCE-RPCs and pipes
4.3.8
All All
: P5 regression
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-05-05 14:15 UTC by David Woodhouse
Modified: 2016-05-06 09:30 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Woodhouse 2016-05-05 14:15:54 UTC
Also filed as https://bugzilla.redhat.com/show_bug.cgi?id=1333392

'net -k ads join' stopped working after updating (from 4.3.6) to 4.3.8.



# dnf downgrade samba\* libwbclient\* libsmbclient\* ctdb\*
(to 4.3.0, although 4.3.6 also worked)
# net -k ads join GER.CORP.INTEL.COMldb: unable to stat module /usr/lib64/samba/ldb : No such file or directory
Kinit for DWOODHOU-DESK7$ to access cifs/HASGER402.ger.corp.intel.com@GER.CORP.INTEL.COM failed: Preauthentication failed
Using short domain name -- GER
Joined 'DWOODHOU-DESK7' to dns domain 'ger.corp.intel.com'
kerberos_kinit_password DWOODHOU-DESK7$@GER.CORP.INTEL.COM failed: Preauthentication failed
DNS update failed: kinit failed: Preauthentication failed
[root@dwoodhou-desk7 ~]# echo $?
0

... Noisy (and often prompts users to complain), but it worked.

# dnf update
(to 4.3.8)
# net -k ads join GER.CORP.INTEL.COM
ldb: unable to stat module /usr/lib64/samba/ldb : No such file or directory
Kinit for DWOODHOU-DESK7$ to access cifs/HASGER402.ger.corp.intel.com@GER.CORP.INTEL.COM failed: Preauthentication failed
Failed to join domain: failed to verify domain membership after joining: Logon failure


I can provide -d10 output from both on request.
Comment 1 David Woodhouse 2016-05-06 09:30:11 UTC
This appears to be fixed in 4.3.9 by commit 70d872740 ("s3:libsmb: use password = NULL for anonymous connections").

*** This bug has been marked as a duplicate of bug 11858 ***