Bug 11897 - SMB3 multichannel implementation is missing oplock/lease break request replay
Summary: SMB3 multichannel implementation is missing oplock/lease break request replay
Status: RESOLVED FIXED
Alias: None
Product: Samba 4.1 and newer
Classification: Unclassified
Component: File services (show other bugs)
Version: 4.4.3
Hardware: All All
: P5 normal (vote)
Target Milestone: ---
Assignee: Michael Adam
QA Contact: Samba QA Contact
URL:
Keywords:
: 12376 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-05-04 19:23 UTC by Michael Adam
Modified: 2020-09-09 16:39 UTC (History)
8 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Adam 2016-05-04 19:23:46 UTC
In order to prevent data corruption, if an oplock/lease break request sent from the smb server to the client does not get a response, (if the channel failed) the server needs to resend the break request over other channels as long as there are intact channels left in the (multi-channel) session.

This is required in order to move the multichannel feature from experimental to supported. The purpose of this bug is to track this piece of technical debt.
Comment 1 Michael Adam 2016-10-16 19:59:42 UTC
*** Bug 12376 has been marked as a duplicate of this bug. ***
Comment 2 Stefan Metzmacher 2020-07-24 15:52:28 UTC
This is fixed with 883657a7cfe0788b8c82b58a0379a8ea724df72a in 4.13.0rc1
Comment 3 David Disseldorp 2020-09-09 14:20:37 UTC
(In reply to Stefan Metzmacher from comment #2)
> This is fixed with 883657a7cfe0788b8c82b58a0379a8ea724df72a in 4.13.0rc1

Thanks a lot for fixing this, Metze! Unless I'm missing something, we could now consider removing, or at least toning down, the "this feature is still considered experimental" warning in the manpage. What do you think?
Comment 4 Stefan Metzmacher 2020-09-09 16:39:42 UTC
(In reply to David Disseldorp from comment #3)

We still have these before we can thing about it:
https://bugzilla.samba.org/show_bug.cgi?id=11899
https://bugzilla.samba.org/show_bug.cgi?id=14433
https://bugzilla.samba.org/show_bug.cgi?id=14449

I hope to get to them for 4.14.

We also need people doing real world testing with real hardware
and windows clients.

See also https://www.samba.org/~metze/presentations/2020/SDC/
for my status update