Bug 11859 - Samba 4.2.4-34.1 cannot access Windows 10 machine with no password set
Samba 4.2.4-34.1 cannot access Windows 10 machine with no password set
Status: RESOLVED DUPLICATE of bug 11841
Product: Samba 4.1 and newer
Classification: Unclassified
Component: File services
4.2.4
All Linux
: P5 normal
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-04-19 17:10 UTC by hrm-temp@sonic.net
Modified: 2016-04-20 10:03 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hrm-temp@sonic.net 2016-04-19 17:10:10 UTC
Systems are openSUSE 13.2, KDE, both 32-bit and 64-bit

With samba 4.2.4-34.1, in Dolphin when I do Network->Samba Shares->(workgroup name)->(name of Windows 10 machine), an authentication window appears wanting user name and password. The Windows 10 machine does have a user name, but no password. No matter what I put in the authentication fields, access is denied.

Running samba 4.1.23-31.1, in Dolphin I could click Network->Samba Shares->(workgroup name)->(name of Windows 10 machine) and got a list of six folders, one of which is shared. Clicking the shared folder, I'm in with read and write access. No authentication window appears.

Samba 4.2.4-34.1 will access openSUSE systems with passwords, and Windows 10 systems with passwords, but for the Windows 10 system with no password, access is denied. This problem does not occur with samba 4.1.23-31.1
Comment 1 Stefan Metzmacher 2016-04-20 10:03:41 UTC

*** This bug has been marked as a duplicate of bug 11841 ***