Bug 11803 - rsync protocol (selection/compatibility) problem
rsync protocol (selection/compatibility) problem
Status: RESOLVED DUPLICATE of bug 10532
Product: rsync
Classification: Unclassified
Component: core
All All
: P5 normal
: ---
Assigned To: Wayne Davison
Rsync QA Contact
Depends on:
  Show dependency treegraph
Reported: 2016-03-20 07:51 UTC by skraw
Modified: 2016-06-15 05:53 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description skraw 2016-03-20 07:51:05 UTC
If using rsync as daemon for various newer and older rsync clients it seems the latest version (3.1.2 protocol 31) does not work together well with older versions, especially protocol 26 from 2.5.6. It does not connect. How did you expect a user should configure the daemon for such a use? It seems there is no protocol setting option in the conf file. So one cannot restrict an incoming connection from an older rsync client to a certain protocol. The global --protocol is pretty useless for this...
Comment 1 Ged Haywood 2016-06-08 19:30:18 UTC
Any progress on this?
Comment 2 Wayne Davison 2016-06-15 05:53:01 UTC

*** This bug has been marked as a duplicate of bug 10532 ***