Bug 112 - autogen.sh doesn't work with $builddir != $srcdir
autogen.sh doesn't work with $builddir != $srcdir
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.0preX
Other other
: P2 normal
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-22 18:39 UTC by Tim Potter
Modified: 2005-02-07 07:57 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Potter 2003-05-22 18:39:25 UTC
Should autogen.sh create its files in $builddir or $srcdir?

I had a poke around the web and it looks like everyone else's autogen.sh scripts
create stuff in $srcdir.
Comment 1 David Lee 2003-05-23 10:17:06 UTC
The general principle of allowing $builddir and $srcdir to differ
is _usually_ good.  (E.g. see bug 83.)  For instance a site with multiple
architectures can have many $builddir all mutually independent,
maintained from a common, effectively read-only, $srcdir.

But I don't think that principle applies to "autogen.sh", whose job is much
earlier in the chain, building the "configure" script etc. in the first place.
Indeed, the whole purpose of "configure" is to be common across everything.
The typical end-site will run "./configure" on whatever they have, and it is
only AFTER configure, not before, that system-dependencies enter the picture.

By far the primary purpose of autogen.sh is to assist the package maintainers:
the Samba team, and the relatively few folk who diddle with ".in" files.
The typical "grab the 'tar' file" site will simply use the common "configure",
itself generated by those package maintainers.

So, despite my being a strong advocate of clear separation of $srcdir from
possibly multiple $builddir, I think that "autogen.sh" is the exception
to that good general rule.

(There may be a residual counter-argument in favour of autogen.sh separation
(of $builddir and $srcdir) for those "pre-configure" folk who wish to test
different versions of autoconf itself...)

Hope that helps the thought-process!
Comment 2 Tim Potter 2003-05-23 18:30:38 UTC
David, your argument was pretty similiar to mine for keeping things the way they
are.  I couldn't decide either way but after reading your comments I think this
is not a bug.
Comment 3 Gerald (Jerry) Carter 2005-02-07 07:57:05 UTC
originally reported against 3.0aph24.  Bugzilla spring cleaning.  
Removing old alpha versions.