Bug 11148 - Build fails compiling lib/texpect/texpect.c
Build fails compiling lib/texpect/texpect.c
Status: RESOLVED DUPLICATE of bug 10833
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Build
4.2.0
IA64 FreeBSD
: P5 critical
: ---
Assigned To: Björn Jacke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-10 18:32 UTC by samba
Modified: 2015-03-11 21:02 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description samba 2015-03-10 18:32:05 UTC
[ 685/3559] Compiling lib/tevent/tevent_timed.c
[ 686/3559] Compiling lib/tevent/tevent_util.c
[ 687/3559] Compiling lib/tevent/tevent_wakeup.c
[ 688/3559] Compiling lib/talloc/pytalloc_util.c
[ 689/3559] Compiling lib/talloc/pytalloc.c
[ 690/3559] Compiling lib/tevent/pytevent.c
../lib/tevent/pytevent.c: In function 'py_tevent_context_new':
../lib/tevent/pytevent.c:639: warning: passing argument 4 of 'PyArg_ParseTupleAndKeywords' from incompatible pointer type
[ 691/3559] Compiling lib/texpect/texpect.c
../lib/texpect/texpect.c:79: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'alarmset'
../lib/texpect/texpect.c: In function 'caught_signal':
../lib/texpect/texpect.c:90: error: 'alarmset' undeclared (first use in this function)
../lib/texpect/texpect.c:90: error: (Each undeclared identifier is reported only once
../lib/texpect/texpect.c:90: error: for each function it appears in.)
../lib/texpect/texpect.c: In function 'eval_parent':
../lib/texpect/texpect.c:265: error: 'alarmset' undeclared (first use in this function)
../lib/texpect/texpect.c:265: error: 'SIGALRM' undeclared (first use in this function)
../lib/texpect/texpect.c: In function 'main':
../lib/texpect/texpect.c:391: warning: assignment from incompatible pointer type
../lib/texpect/texpect.c:430: error: storage size of 'sa' isn't known
../lib/texpect/texpect.c:436: error: 'SIGALRM' undeclared (first use in this function)



Config options:

--enable-fhs --exec-prefix=/usr/local --with-configdir=/usr/local/etc  --prefix=/usr/local --with-piddir=/var/run --without-ad-dc --without-ldap --without-ads
Comment 1 samba 2015-03-10 18:49:17 UTC
P.S. sig_atomic_t was properly detected during configure:

Checking for struct sockaddr_storage                         : ok
Checking for sa_family_t                                     : ok
Checking for sig_atomic_t                                    : ok
Checking for inet_ntoa                                       : ok
Checking for inet_aton                                       : ok
Comment 2 samba 2015-03-11 21:02:22 UTC

*** This bug has been marked as a duplicate of bug 10833 ***