Bug 11062 - Administrators SID is invalid
Administrators SID is invalid
Status: RESOLVED DUPLICATE of bug 10720
Product: Samba 4.1 and newer
Classification: Unclassified
All All
: P5 normal
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2015-01-20 11:14 UTC by Charles
Modified: 2015-01-20 18:41 UTC (History)
2 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Charles 2015-01-20 11:14:41 UTC
On a samba 4.2 DC(tested 4.2rc2/rc3/rc4), which has worked well for about a month
now. It
still works for all users except "Administrator".

The problem happen after some time like 15-30 days 

If I login to a Windows box with the Administrator account, I
connect to any shares and clicking on a mapped drive returns the
"The security ID structure is invalid".

Opening "Active Directory Users and Computers" on the Windows box
returns "The RPC server is unavailable".

Using "smbclient -L localhost -UAdministrator" on the GNU/Linux
running samba I receife this error: "session setup failed:

tests with heavy support of the samba list (samba@lists.samba.org) has put in evidence two way to resolve the problem.

first by Roland Penny

second by Andrew Bartlett

Comment 1 Andrew Bartlett 2015-01-20 11:26:44 UTC
If you installed Samba 4.2 before rc4, ensure you have run 'net cache flush' to clear the bad cache entry.

This issue is fixed in 4.2rc4.  Please do not re-open or re-file unless you can reproduce on a domain that was either NOT running a prior version of Samba 4.2, or has already had 'net cache flush' run since the upgrade.

*** This bug has been marked as a duplicate of bug 10720 ***