Bug 11029 - Incorrect bad password attempt
Incorrect bad password attempt
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: AD: LDB/DSDB/SAMDB
4.2.0rc3
All Windows 7
: P5 major
: 4.2
Assigned To: Andrew Bartlett
Samba QA Contact
:
: 11539 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-01-05 08:03 UTC by Om Parkash Maurya
Modified: 2016-07-29 02:38 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Om Parkash Maurya 2015-01-05 08:03:38 UTC
Hello Team

I'm running Samba 4.2.0rc3 for test implementation. I've enabled lockout policy using samba-tools. I've noticed below bugs.

Server Environment: CentOS 6.x
Client Environment: CentOS 6.x/Windows 7

1. Password policy is not working using Default Domain Policy using Windows GPMC.
2. Bad password count working fine using non-windows clients but on windows platform bad password count gets doubled (For single bad password attempt it counts 2).
3. GP result from windows box shows each configured GPO empty and so comes under denied/not applied, but RSOP reflects those settings.

Rest seems to be working perfectly, Many thanks for your great work..!!

Regards,
- Om
Comment 1 Stefan Metzmacher 2015-01-05 08:30:51 UTC
Andrew, can you please check if 2. is a real bug we should fix for 4.2.0?
Comment 2 Stefan Metzmacher 2015-01-05 08:34:19 UTC
(In reply to Om Parkash Maurya from comment #0)

Samba doesn't look at GPOs itself at all yet, sorry.
This is tracked in bug #6613.
Comment 3 Stefan Metzmacher 2015-01-26 21:25:35 UTC
I don't think this is a 4.2.0 blocker
Comment 4 Andrew Bartlett 2016-07-29 02:38:04 UTC
Fixed with 978bc8681e74ffa17f96fd5d4355094c4a26691c in Samba 4.5rc1
Comment 5 Andrew Bartlett 2016-07-29 02:38:28 UTC
*** Bug 11539 has been marked as a duplicate of this bug. ***