Bug 10784 - Using NTLM_AUTH does not authenticate against 2012 R2 domain server.
Using NTLM_AUTH does not authenticate against 2012 R2 domain server.
Status: NEW
Product: Samba 4.1 and newer
Classification: Unclassified
Component: DCE-RPCs and pipes
4.1.11
x64 Linux
: P5 normal
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-08-26 11:05 UTC by David Hubner
Modified: 2015-07-31 08:33 UTC (History)
1 user (show)

See Also:


Attachments
Windows 7 client connecting to proxy and proxy connection to AD (9.25 KB, application/vnd.tcpdump.pcap)
2014-08-26 11:05 UTC, David Hubner
no flags Details
Winbindd in debug level 10 mode while request is made (107.72 KB, text/x-log)
2014-08-26 11:06 UTC, David Hubner
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Hubner 2014-08-26 11:05:46 UTC
Created attachment 10227 [details]
Windows 7 client connecting to proxy and proxy connection to AD

Hi, 

I am trying to use ntlm_auth with squid to authenticate against a Windows 2012 R2 AD from a windows 7 client. Each time it happens I get back NT_STATUS_WRONG_PASSWORD. I have been investigating the issue and have not been able to resolve it. 

I am attaching the winbindd logs and packet dump from the proxy server. Checking between the different versions of source3 and source4 I cannot really see any difference apart from seal and sign encryption of the dcerpc request. 

If you need anymore information just give us a shout. 

Thanks
Comment 1 David Hubner 2014-08-26 11:06:19 UTC
Created attachment 10228 [details]
Winbindd in debug level 10 mode while request is made
Comment 2 David Hubner 2014-08-26 11:11:34 UTC
Just a little more information:

The password is correct, I have created 3-4 accounts and changed the password loads of times just to make sure :)