Bug 10709 - objectclass_attrs: attribute 'msTSExpireDate' on entry '...' contains at least one invalid value
objectclass_attrs: attribute 'msTSExpireDate' on entry '...' contains at leas...
Status: RESOLVED DUPLICATE of bug 9810
Product: Samba 4.1 and newer
Classification: Unclassified
Component: AD: LDB/DSDB/SAMDB
4.1.9
All All
: P5 normal
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-11 17:53 UTC by Marc Muehlfeld
Modified: 2014-07-24 11:51 UTC (History)
0 users

See Also:


Attachments
Level 10 debug log (805.96 KB, application/x-gzip)
2014-07-11 17:53 UTC, Marc Muehlfeld
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Muehlfeld 2014-07-11 17:53:43 UTC
Created attachment 10099 [details]
Level 10 debug log

I setup a Windows 2012R2 TS. Everything seems to work, but Windows logs the following error

> TerminalServices-Licensing 4105 – The Terminal Services license server
> cannot update the license attributes for user “<UserName>” in Active 
> Directory Domain “<DomainName>”

because the TS machine can't update a TS attribute on user accounts.




A level 10 debug log shows:

[2014/07/11 19:31:51.198275, 10, pid=113230, effective(0, 0), real(0, 0), class=ldb] ../lib/ldb-samba/ldb_wrap.c:71(ldb_wrap_debug)
  ldb: ldb_asprintf/set_errstring: objectclass_attrs: attribute 'msTSExpireDate' on entry 'CN=muehlfeld,CN=Users,DC=muc,DC=medizinische-genetik,DC=de' contains at least one invalid value!




This page 

> http://www.snix.com/wiki/index.php/Samba_4 

page describes this error and provides a possible patch that should add a handler for date strings to fix the issue.

At least to 4.1.9, this patch doesn't apply smoothly. But if you think this fixes the issue, maybe it helps to write a patch for the latest Samba versions.
Comment 1 Andrew Bartlett 2014-07-24 05:42:14 UTC
Thanks for looking into this.  I did a patch about 9 months ago for this, and it failed review for trivial reasons (missing a BUG:, for example) and (sadly) I didn't follow it up after that.  

Yes, as far as I see it is just a matter of accepting even more time formats.
Comment 2 Björn Jacke 2014-07-24 11:51:04 UTC
this is a dup. Arvid already reported this with a patch attached. A torture test is missing I think...

*** This bug has been marked as a duplicate of bug 9810 ***