Bug 10602 - Configure error on FreeBSD 8.1-RELEASE
Configure error on FreeBSD 8.1-RELEASE
Status: RESOLVED DUPLICATE of bug 10472
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Build
4.1.7
x64 FreeBSD
: P5 normal
: ---
Assigned To: Björn Jacke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-05-09 19:53 UTC by samba
Modified: 2014-05-10 08:30 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description samba 2014-05-09 19:53:17 UTC
Checking for CC_MD5_Init                                                                        : not found
Checking for CC_MD5_Init                                                                        : not found
Traceback (most recent call last):
  File "./buildtools/bin/waf", line 76, in <module>
    Scripting.prepare(t, cwd, VERSION, wafdir)
  File "/root/_build/samba/samba-4.1.7/buildtools/wafadmin/Scripting.py", line 145, in prepare
    prepare_impl(t, cwd, ver, wafdir)
  File "/root/_build/samba/samba-4.1.7/buildtools/wafadmin/Scripting.py", line 135, in prepare_impl
    main()
  File "/root/_build/samba/samba-4.1.7/wscript", line 280, in main
    wildcard_main(wildcard_cmd)
  File "./buildtools/wafsamba/samba_wildcard.py", line 110, in wildcard_main
    fun(ctx)
  File "/root/_build/samba/samba-4.1.7/buildtools/wafadmin/Scripting.py", line 241, in configure
    conf.sub_config([''])
  File "/root/_build/samba/samba-4.1.7/buildtools/wafadmin/Configure.py", line 237, in sub_config
    self.recurse(k, name='configure')
  File "/root/_build/samba/samba-4.1.7/buildtools/wafadmin/Utils.py", line 634, in recurse
    f(self)
  File "/root/_build/samba/samba-4.1.7/wscript", line 140, in configure
    conf.RECURSE('pidl')
  File "./buildtools/wafsamba/samba_utils.py", line 469, in RECURSE
    return ctx.sub_config(relpath)
  File "/root/_build/samba/samba-4.1.7/buildtools/wafadmin/Configure.py", line 237, in sub_config
    self.recurse(k, name='configure')
  File "/root/_build/samba/samba-4.1.7/buildtools/wafadmin/Utils.py", line 634, in recurse
    f(self)
  File "/root/_build/samba/samba-4.1.7/pidl/wscript", line 33, in configure
    conf.check_perl_ext_devel()
  File "/root/_build/samba/samba-4.1.7/buildtools/wafadmin/Tools/perl.py", line 104, in check_perl_ext_devel
    conf.env.PERL_VENDORARCH_DIR = read_out('print $Config{vendorarch}')[0]
IndexError: list index out of range
*** Error code 1
Comment 1 samba 2014-05-09 19:55:48 UTC
Configure flags:

./configure --enable-fhs --exec-prefix=/usr/local --with-configdir=/usr/local/etc --prefix=/usr/local --with-piddir=/var/run

4.1.6 compiled just fine on the same system with the same configure line.
Comment 2 Stefan Metzmacher 2014-05-10 08:30:21 UTC

*** This bug has been marked as a duplicate of bug 10472 ***