Bug 10476 - WAF does not build / install shared libraries properly on OpenBSD
WAF does not build / install shared libraries properly on OpenBSD
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Build
All OpenBSD
: P5 major
: 4.2
Assigned To: Karolin Seeger
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2014-02-27 23:04 UTC by Brad Smith
Modified: 2015-03-15 20:58 UTC (History)
4 users (show)

See Also:

proposed patch for 4.2 (2.59 KB, patch)
2015-03-04 16:53 UTC, Michael Adam
vl: review+

Note You need to log in before you can comment on or make changes to this bug.
Description Brad Smith 2014-02-27 23:04:45 UTC
At the moment the WAF build infrastructure is broken on OpenBSD with regard to building and installing shared libraries. This prevents us from moving past 3.6.15. I posted about this to the Samba-technical list to see if I could get anyones attention and see about having Samba's forked copy of WAF fixed but haven't seen anyone reply so far. WAF upstream has been fixed to correctly deal with shared libraries on OpenBSD.

Comment 1 Ian McWilliam 2014-05-05 13:16:43 UTC
Any word on the status of this. It's makes porting samba 4 to OpenBSD all the more difficult.
Comment 2 Michael Adam 2015-03-04 16:53:07 UTC
Created attachment 10816 [details]
proposed patch for 4.2
Comment 3 Michael Adam 2015-03-04 17:18:33 UTC
Karo, please pick to 4.2 as appropriate. Thanks!
Comment 4 Michael Adam 2015-03-04 17:20:58 UTC
Not sure if we can still get it into 4.2.0.

We can remove the dep to 10077 again if it is too late.
Comment 5 Björn Jacke 2015-03-04 22:08:50 UTC
this is a valid patch for the release branches but no regression and no blocker
Comment 6 Karolin Seeger 2015-03-09 20:59:43 UTC
Pushed to autobuild-v4-2-test.
Comment 7 Karolin Seeger 2015-03-15 20:58:39 UTC
Pushed to v4-2-test.
Closing out bug report.