Bug 10464 - samba4 services not binding on IPv6 addresses causing connection delays
samba4 services not binding on IPv6 addresses causing connection delays
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: AD: LDB/DSDB/SAMDB
4.1.5
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-22 10:50 UTC by Björn Jacke
Modified: 2014-04-04 18:53 UTC (History)
1 user (show)

See Also:


Attachments
Patches for v4-1-test (8.39 KB, patch)
2014-03-17 12:28 UTC, Stefan Metzmacher
abartlet: review+
Details
Patches for v4-0-test (8.39 KB, patch)
2014-03-17 12:28 UTC, Stefan Metzmacher
abartlet: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Jacke 2014-02-22 10:50:36 UTC
samba 4 does not listen on the right interface IPs. smb.conf is a plain fresh
dcpromoed DC without any interfaces or bind interfaces only parameters. I
noticed that the interface bindings are broken, because DNS queries on
localhost (which tries ::1 via UDP first) takes 1s per query :-(

netstat shows that :53 and all samba4 services are only listening on 0.0.0.0

just the smbd subprocess also listens on v6.

In case this is kernel/distribution related (I didn't check other setups for
this): this behaviour is on linux 3.11.10, glibc 2.18 on opensuse 13.1.


# netstat -anp | grep LISTEN
tcp    0   0 0.0.0.0:53         0.0.0.0:*        LISTEN      8212/samba          
tcp    0   0 0.0.0.0:22         0.0.0.0:*        LISTEN      1143/sshd           
tcp    0   0 0.0.0.0:88         0.0.0.0:*        LISTEN      8206/samba          
tcp    0   0 0.0.0.0:636        0.0.0.0:*        LISTEN      8204/samba          
tcp    0   0 0.0.0.0:445        0.0.0.0:*        LISTEN      8201/smbd           
tcp    0   0 0.0.0.0:1024       0.0.0.0:*        LISTEN      8200/samba          
tcp    0   0 0.0.0.0:3268       0.0.0.0:*        LISTEN      8204/samba          
tcp    0   0 0.0.0.0:3269       0.0.0.0:*        LISTEN      8204/samba          
tcp    0   0 0.0.0.0:389        0.0.0.0:*        LISTEN      8204/samba          
tcp    0   0 0.0.0.0:135        0.0.0.0:*        LISTEN      8200/samba          
tcp    0   0 0.0.0.0:139        0.0.0.0:*        LISTEN      8201/smbd           
tcp    0   0 0.0.0.0:464        0.0.0.0:*        LISTEN      8206/samba          
tcp    0   0 :::445             :::*             LISTEN      8201/smbd           
tcp    0   0 :::139             :::*             LISTEN      8201/smbd
Comment 1 Björn Jacke 2014-03-06 10:33:24 UTC
so far

sysctl -w net.ipv6.conf.all.disable_ipv6=1

is the best thing that people can do. Maybe we should we put this recommendation in the release notesso that people have a chance to work around that problem, especially as it is not obvious at all that the 1s DNS delay is caused by this bug.
Comment 2 Björn Jacke 2014-03-17 12:23:18 UTC
looks like this was fixed, reviewed and pushed to master already. Unfortunately bugzilla was completely left out. See f7883ae02a4e8935a44396f776712cebfd411e52 and a571fe520d09a00273a58b1fb0fa9aab8e0aefce

Karo, can you please pick them to 4.1 ?
Comment 3 Stefan Metzmacher 2014-03-17 12:28:00 UTC
Created attachment 9778 [details]
Patches for v4-1-test
Comment 4 Stefan Metzmacher 2014-03-17 12:28:53 UTC
Created attachment 9779 [details]
Patches for v4-0-test
Comment 5 Karolin Seeger 2014-03-25 09:53:13 UTC
Pushed to autobuild-v4-1-test and autobuild-v4-0-test.
Comment 6 Karolin Seeger 2014-04-04 18:53:57 UTC
Pushed to v4-0-test and v4-1-test.
Closing out bug report.

Thanks!