Bug 10441 - smbd "internal error" panic
smbd "internal error" panic
Status: RESOLVED DUPLICATE of bug 10415
Product: Samba 4.0
Classification: Unclassified
Component: File services
4.0.14
x64 FreeBSD
: P5 normal
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-12 10:41 UTC by sascha
Modified: 2014-02-13 15:32 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sascha 2014-02-12 10:41:59 UTC
i recently upgraded from 4.0.12 to 4.0.14 an started getting thos panics in my log. Does anyone may have an idea whats going on? Any advise in further investigations?

Feb 12 11:36:12 mercury smbd[6736]: [2014/02/12 11:36:12.326922,  0, pid=6736, effective(3000028, 20), real(0, 0)] ../lib/util/fault.c:72(fault_report)
Feb 12 11:36:12 mercury smbd[6736]:   ===============================================================
Feb 12 11:36:12 mercury smbd[6736]: [2014/02/12 11:36:12.327016,  0, pid=6736, effective(3000028, 20), real(0, 0)] ../lib/util/fault.c:73(fault_report)
Feb 12 11:36:12 mercury smbd[6736]:   INTERNAL ERROR: Signal 11 in pid 6736 (4.0.14)
Feb 12 11:36:12 mercury smbd[6736]:   Please read the Trouble-Shooting section of the Samba HOWTO
Feb 12 11:36:12 mercury smbd[6736]: [2014/02/12 11:36:12.327063,  0, pid=6736, effective(3000028, 20), real(0, 0)] ../lib/util/fault.c:75(fault_report)
Feb 12 11:36:12 mercury smbd[6736]:   ===============================================================
Feb 12 11:36:12 mercury smbd[6736]: [2014/02/12 11:36:12.327109,  0, pid=6736, effective(3000028, 20), real(0, 0)] ../source3/lib/util.c:810(smb_panic_s3)
Feb 12 11:36:12 mercury smbd[6736]:   PANIC (pid 6736): internal error
Feb 12 11:36:12 mercury smbd[6736]: [2014/02/12 11:36:12.327649,  0, pid=6736, effective(3000028, 20), real(0, 0)] ../source3/lib/util.c:921(log_stack_trace)
Feb 12 11:36:12 mercury smbd[6736]:   BACKTRACE: 25 stack frames:
Feb 12 11:36:12 mercury smbd[6736]:    #0 0x82945ecd <smb_panic_s3+45> at /usr/local/lib/libsmbconf.so.0
Feb 12 11:36:12 mercury smbd[6736]:    #1 0x81462a3c <smb_panic+44> at /usr/local/lib/libsamba-util.so.0
Feb 12 11:36:12 mercury smbd[6736]:    #2 0x81462c51 <smb_panic+577> at /usr/local/lib/libsamba-util.so.0
Feb 12 11:36:12 mercury smbd[6736]:    #3 0x83f8e349 <pthread_sigmask+889> at /lib/libthr.so.3
Feb 12 11:36:12 mercury smbd[6736]:    #4 0x83f8e579 <pthread_sigmask+1449> at /lib/libthr.so.3
Feb 12 11:36:12 mercury smbd[6736]:    #5 0x7ffffffff003
Feb 12 11:36:12 mercury smbd[6736]:    #6 0x81727854 <file_free+196> at /usr/local/lib/samba/libsmbd_base.so
Feb 12 11:36:12 mercury smbd[6736]:    #7 0x8177978a <smbd_check_access_rights+6202> at /usr/local/lib/samba/libsmbd_base.so
Feb 12 11:36:12 mercury smbd[6736]:    #8 0x8177cbb1 <create_file_default+417> at /usr/local/lib/samba/libsmbd_base.so
Feb 12 11:36:12 mercury smbd[6736]:    #9 0x81852e63 <vfs_default_init+10467> at /usr/local/lib/samba/libsmbd_base.so
Feb 12 11:36:12 mercury smbd[6736]:    #10 0x81782bb0 <smb_vfs_call_create_file+128> at /usr/local/lib/samba/libsmbd_base.so
Feb 12 11:36:12 mercury smbd[6736]:    #11 0x817b2d27 <smbd_smb2_request_process_create+4055> at /usr/local/lib/samba/libsmbd_base.so
Feb 12 11:36:12 mercury smbd[6736]:    #12 0x817ab2cd <smbd_smb2_request_dispatch+3133> at /usr/local/lib/samba/libsmbd_base.so
Feb 12 11:36:12 mercury smbd[6736]:    #13 0x817abf56 <smbd_smb2_request_dispatch+6342> at /usr/local/lib/samba/libsmbd_base.so
Feb 12 11:36:12 mercury smbd[6736]:    #14 0x817ac1b6 <smbd_smb2_request_dispatch+6950> at /usr/local/lib/samba/libsmbd_base.so
Feb 12 11:36:12 mercury smbd[6736]:    #15 0x8295a6f8 <run_events_poll+632> at /usr/local/lib/libsmbconf.so.0
Feb 12 11:36:12 mercury smbd[6736]:    #16 0x8295ab31 <event_add_to_poll_args+929> at /usr/local/lib/libsmbconf.so.0
Feb 12 11:36:12 mercury smbd[6736]:    #17 0x841a8d41 <_tevent_loop_once+145> at /usr/local/lib/libtevent.so.0
Feb 12 11:36:12 mercury smbd[6736]:    #18 0x81796c83 <smbd_process+2723> at /usr/local/lib/samba/libsmbd_base.so
Feb 12 11:36:12 mercury smbd[6736]: [2014/02/12 11:36:12.328108,  0, pid=6736, effective(0, 0), real(0, 0)] ../source3/lib/dumpcore.c:317(dump_core)
Feb 12 11:36:12 mercury smbd[6736]:   dumping core in /var/coredumps
Feb 12 11:36:12 mercury smbd[6736]:
Feb 12 11:36:12 mercury kernel: pid 6736 (smbd), uid 0: exited on signal 6
Comment 1 Volker Lendecke 2014-02-12 11:59:18 UTC
While the traces here are not sufficient, have you seen https://bugzilla.samba.org/show_bug.cgi?id=10415 ?
Comment 2 sascha 2014-02-13 15:32:11 UTC
I applied the given patch for the 4.0.next branch and the panics are gone so far. Thanks Volker!

*** This bug has been marked as a duplicate of bug 10415 ***