Bug 10432 - build successful, but binaries don't run
build successful, but binaries don't run
Status: RESOLVED DUPLICATE of bug 9557
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Build
4.1.4
PPC AIX
: P5 normal
: ---
Assigned To: Björn Jacke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-08 09:55 UTC by Peter
Modified: 2014-02-09 11:33 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter 2014-02-08 09:55:58 UTC
AIX 7.1, xlc 12.1, python 2.7.6

I build samba with:

./configure --prefix=/usr/local/samba/samba-4.1.4 \
          --sysconfdir=/usr/local/samba/conf --localstatedir=/var/samba/smb \
          --mandir=/usr/local/samba/samba-4.1.4/man --with-privatedir=/usr/local/samba/conf \
          --with-configdir=/usr/local/samba/conf --with-piddir=/var/samba/smb/pids \
          --with-logfilebase=/var/samba/smb/logs --with-acl-support --with-winbind \
          --with-ldap 

make
make install

Trying to start samba gives following error:

# ./RCsamba start 
delete tdb files stored in the samba lock directory
/usr/local/samba/current/sbin/smbd -Dexec(): 0509-036 Cannot load program /usr/local/samba/current/sbin/smbd because of the following errors:
        0509-150   Dependent module libsamba-util.so could not be loaded.
        0509-022 Cannot load module libsamba-util.so.
        0509-026 System error: A file or directory in the path name does not exist.
                          done
/usr/local/samba/current/sbin/nmbd -Dexec(): 0509-036 Cannot load program /usr/local/samba/current/sbin/nmbd because of the following errors:
        0509-150   Dependent module libpopt_samba3.so could not be loaded.
        0509-022 Cannot load module libpopt_samba3.so.
        0509-026 System error: A file or directory in the path name does not exist.
                          done
Comment 1 Christian Ambach 2014-02-09 11:33:47 UTC

*** This bug has been marked as a duplicate of bug 9557 ***