Bug 10364 - send_xattr_request: Assertion `f_out >= 0' failed.
send_xattr_request: Assertion `f_out >= 0' failed.
Status: RESOLVED DUPLICATE of bug 10290
Product: rsync
Classification: Unclassified
Component: core
3.1.0
All All
: P5 normal
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-08 16:58 UTC by Xose Vazquez Perez
Modified: 2014-01-12 21:53 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xose Vazquez Perez 2014-01-08 16:58:58 UTC
Fedora 20 x86_64:
rsync-3.1.0-1pre1.fc20.x86_64
kernel-3.12.6-300.fc20.x86_64

# rsync   --exclude='/swapfile' \
          --exclude='/home/*/.gvfs' \
          --exclude='/tmp/*' \
          --exclude='/var/tmp/*' \
          -A -X -a -H -x -v --delete / /mybook/raiz-t61-p.f20/
[...]
var/lib/mlocate/mlocate.db
rsync: xattrs.c:572: send_xattr_request: Assertion `f_out >= 0' failed.
rsync: connection unexpectedly closed (35060 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at io.c(226) [sender=3.1.0pre1]

# df | grep ext4
/dev/sda1 on / type ext4 (rw,noatime,discard,data=ordered)
/dev/sdb on /mybook type ext4 (rw,noatime,data=ordered)
Comment 1 Xose Vazquez Perez 2014-01-08 17:00:12 UTC
Fedora bug: http://bugzilla.redhat.com/show_bug.cgi?id=1050081
Comment 2 Xose Vazquez Perez 2014-01-09 11:08:42 UTC
It also happens with 3.1.0 ( rsync-3.1.0-2.fc20.x86_64 )
Comment 3 Wayne Davison 2014-01-12 21:53:39 UTC

*** This bug has been marked as a duplicate of bug 10290 ***