Bug 10068 - glusterfs volume capacity reported to Windows is incorrect
glusterfs volume capacity reported to Windows is incorrect
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: VFS Modules
4.1.0rc1
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 09:18 UTC by Susant Kumar Palai
Modified: 2013-11-06 11:32 UTC (History)
0 users

See Also:


Attachments
git-am fix for master. (1.61 KB, patch)
2013-08-06 21:43 UTC, Jeremy Allison
no flags Details
patch with cherry-pick and bug number information (1.75 KB, patch)
2013-10-31 22:28 UTC, Björn Jacke
bjacke: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Susant Kumar Palai 2013-08-05 09:18:21 UTC
When a gluster volume is mounted on a Windows client as a network drive letter, the capacity displayed by Windows is incorrect.  Each 1GB brick shows 4TB on Windows, 10GB bricks show 40TB.

Version-Release number of selected component (if applicable):
Windows7 client
glusterfs 3.4.0.12rhs.beta6 built on Jul 23 2013 16:20:03
RHS-2.1-20130724.n.0-RHS-x86_64-DVD1.iso

How reproducible:
Capacity is displayed by Windows Explorer 

Steps to Reproduce:
1. Create Gluster volume
2. Mount as network drive letter on Windows client (not just browse to share)
 
  
Actual results:
Network drive letter claims to be 40,000 times larger than it is.

Expected results:
Drive letter should report actual capacity.
Comment 1 Jeremy Allison 2013-08-06 21:43:49 UTC
Created attachment 9112 [details]
git-am fix for master.

I think this is what you meant. Can you confirm and I'll get it shipped.

Jeremy.
Comment 2 Susant Kumar Palai 2013-08-07 07:25:28 UTC
(In reply to comment #1)
> Created attachment 9112 [details]
> git-am fix for master.
> 
> I think this is what you meant. Can you confirm and I'll get it shipped.
> 
> Jeremy.


yes Jeremy, this should be it.

Susant
Comment 3 Björn Jacke 2013-10-31 07:45:52 UTC
Jeremy, this seems to be ready to be pushed to master and 4.1, right?
Comment 4 Jeremy Allison 2013-10-31 16:32:42 UTC
(In reply to comment #3)
> Jeremy, this seems to be ready to be pushed to master and 4.1, right?

Oh, did it not get in ? I'll post on samba-technical and ask for formal review.

Thanks.

Jeremy.
Comment 5 Jeremy Allison 2013-10-31 21:20:58 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > Jeremy, this seems to be ready to be pushed to master and 4.1, right?
> 
> Oh, did it not get in ? I'll post on samba-technical and ask for formal review.

Ah, just checked - it did get into master as commit a973b1ce7a94bd3f11432a6f32b9d9b13b868dfb.

Yes, this is good to go for 4.1.next.

Re-assigning to Karolin for inclusion.

Jeremy.
Comment 6 Björn Jacke 2013-10-31 22:28:37 UTC
Created attachment 9356 [details]
patch with cherry-pick and bug number information
Comment 7 Björn Jacke 2013-10-31 22:32:50 UTC
looks good, karo, please pick to 4.1, reopening until it's in 4.1
Comment 8 Karolin Seeger 2013-11-06 11:32:31 UTC
Already in v4-1-test (cfa1739f4).
Closing out bug report.

Thanks!