Bug 10011 - Wrong "used" size reported on a Win8 quotad folder mounted using mount -t cifs on linux
Wrong "used" size reported on a Win8 quotad folder mounted using mount -t cif...
Status: RESOLVED DUPLICATE of bug 9281
Product: CifsVFS
Classification: Unclassified
Component: kernel fs
2.6
All All
: P5 normal
: ---
Assigned To: Steve French
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 11:05 UTC by Matt ford
Modified: 2014-11-06 13:11 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt ford 2013-07-11 11:05:55 UTC
I tested quota reporting against a Win8 Server via cifs-utils 6.0 (on a Fedora box) with SMB2.0 and it's not quite what one might expect.

It glitches on the Used column returning what on the test server system looks
to be the remaining free space on the drive overall.  Guessing that it
is the result of mixing folder and drive sizes in the likely
calculation totalsize - freespace = used.  In this case the "folder"
total size approaches zero (100M) and the free space is the figure at
drive level not folder..hence the negative value below.

sudo mount -t cifs //testserver/test mnt/ --verbose -ouser=zzalsmf3,domain
=ds,uid=1000,gid=1000,vers=2.0

df -hv
Filesystem                         Size  Used Avail Use% Mounted on
//130.88.88.173/test               100M -160G   50M 101% /home/matt/mnt/isilon
Comment 1 Jeff Layton 2013-11-01 15:48:37 UTC
I don't consider this a bug. statfs() reports information about the drive at large, not information about the amount available to a specific user. This info is better presented via the quota tools, but that will require some VFS layer work since the quota API currently operates on block devices.

cc'ing Sachin since he was looking at this a while back...
Comment 2 Jeff Layton 2013-11-01 15:49:38 UTC
...also, this a kernel problem, not a userland one...
Comment 3 Björn Jacke 2014-11-06 13:11:22 UTC

*** This bug has been marked as a duplicate of bug 9281 ***